[Contacts] [sharing] Need an icon for contacts sharing in the Comms theme

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmcf, Assigned: jmcf)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

Assignee

Description

4 years ago
For the contacts sharing functionality that is landing on v2.2 we need such an icon.
Assignee

Updated

4 years ago
See Also: → 1113605

Comment 1

4 years ago
Attached the share icon for contact detail. Let me know if you need anything else. Thanks!
Assignee

Comment 2

4 years ago
Posted file PR to GH
Attachment #8548061 - Flags: ui-review?(fshih)
Assignee

Comment 3

4 years ago
Posted image Final Result Capture
Assignee

Updated

4 years ago
Attachment #8548064 - Attachment description: 2015-01-13-10-46-21.png → Final Result Capture

Comment 4

4 years ago
Comment on attachment 8548061 [details] [review]
PR to GH

Looks great! Thanks!
Attachment #8548061 - Flags: ui-review?(fshih) → ui-review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Duplicate of this bug: 1121390
Assignee

Comment 6

4 years ago
https://github.com/mozilla-b2g/gaia/commit/fa8a10ee2e0a6a63b932557dae804dda08e39005
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 7

4 years ago
Comment on attachment 8548061 [details] [review]
PR to GH

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Share contact feature
[User impact] if declined: High, incorrect visuals 
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): No risk patch
[String changes made]:
Attachment #8548061 - Flags: approval-gaia-v2.2?
Assignee

Updated

4 years ago
Depends on: 1113605
Assignee: nobody → jmcf
Keywords: checkin-needed
Target Milestone: --- → 2.2 S4 (23jan)
Attachment #8548061 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Needs rebasing for v2.2.
Flags: needinfo?(jmcf)
Ah, no wonder why. Bug 1113605 didn't make it in time for the v2.2 branching.
Flags: needinfo?(jmcf)
Nominate this to 2.2, needed for bug 1113605.
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Gaia::Contacts]
triage: we need this to make clear UI
blocking-b2g: 2.2? → 2.2+
This issue is verified fixed on Flame 2.2 and on Flame 3.0 master.

See attached screenshot for the correct sharing icon for a contact.

Device: Flame 2.2
BuildID: 20150203002504
Gaia: cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko: 11d93135c678
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0 Master
BuildID: 20150203055641
Gaia: ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko: ae5d04409cd9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::Contacts] → [QAnalyst-Triage+][COM=Gaia::Contacts]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.