[10.10] Firefox crash in libsystem_platform.dylib@0x4caf

RESOLVED WORKSFORME

Status

()

defect
P2
critical
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

(Blocks 1 bug, {crash})

37 Branch
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-d076b0e1-4cd8-467c-989f-358ac2150105.
=============================================================

Seen while looking at crash stats for 36 (showed up in the top changers list). Fairly low volume crash that seems to have many URLs that are youtube or video related. Some of the URLs had embedded video as well.

There have been small volume spikes at times - 2014122921 build had a fair number of crashes.

All the bugs are happening on 10.10. Link to all crashes: https://crash-stats.mozilla.com/report/list?productFirefox&signature=libsystem_platform.dylib@0x4caf




7 	XUL 	mozilla::AppleVTDecoder::InitializeSession() 	dom/media/fmp4/apple/AppleVTDecoder.cpp
8 	XUL 	mozilla::MP4Reader::ReadMetadata(mozilla::MediaInfo*, nsDataHashtable<nsCStringHashKey, nsCString>**) 	dom/media/fmp4/MP4Reader.cpp
9 	XUL 	mozilla::TrackBuffer::InitializeDecoder(mozilla::SourceBufferDecoder*) 	dom/media/mediasource/TrackBuffer.cpp
10 	XUL 	nsRunnableMethodImpl<void (mozilla::TrackBuffer::*)(mozilla::SourceBufferDecoder*), mozilla::SourceBufferDecoder*, true>::Run() 	obj-firefox/x86_64/dist/include/nsThreadUtils.h
11 	XUL 	mozilla::MediaTaskQueue::Runner::Run() 	dom/media/MediaTaskQueue.cpp
12 	XUL 	nsThreadPool::Run() 	xpcom/threads/nsThreadPool.cpp
13 	XUL 	_ZThn8_N12nsThreadPool3RunEv 	obj-firefox/x86_64/xpcom/threads/Unified_cpp_xpcom_threads0.cpp
14 	XUL 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
15 	XUL 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
16 	XUL 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
17 	XUL 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
18 	XUL 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp
19 	libnss3.dylib 	_pt_root

Updated

5 years ago
Blocks: ytb37

Updated

5 years ago
No longer blocks: ytb37

Comment 2

5 years ago
Hi,


I can confirm this bug, even in 35.0.1, 36, and aurora.
I'm running OSX 10.10.1, and crash happen everytime i'm browsing on youtube or any other website that use flash+videos, even using HTML5.

Flash version is 16.0.0.296 (latest).

Here are the latest reports i've made today :

bp-56569d8f-995c-448c-ba22-52dd42150129
bp-454dd954-858b-4a46-81ff-0e12e2150129
bp-4d7c202c-17b6-42c0-975d-8d6402150129
bp-8c2b49e7-f2b4-48c2-989b-67b982150129


Regards,
Nightly is now unusable for me since yesterday due to this bug. One of the 13 app tabs I have open is probably causing this, but I haven't figured out which one yet. My latest crash reports:

bp-4cacf7d7-4187-463c-9593-11ebd2150224
bp-dfd5bc5c-2ac6-4d55-9317-de0d12150224
bp-eae6ce43-18a4-46cb-a6e9-fcab92150224
bp-3287e3de-1a6b-4214-859d-45b582150223
804C8138-3236-45AE-8A3F-6E08DC1DF933
bp-b2e839fa-2772-438f-9e94-55bb62150223
Found it, it was tweetdeck.twitter.com. After closing it, nightly keeps running for more than a few seconds.
Any chances you could identify which video caused the crash ?

And by running for more than a few seconds, do you mean that it still crash somewhere?
Any chance you could provide some logging running a debug version with NSPR_LOG_MODULES=MediaDecoder:5,MediaSource:5,MediaPromise:5,AppleMedia:5,MP4Demuxer:5
Flags: needinfo?(past)
I found another page where the video reliably crashes the content process (w/ flash disabled or not):

http://techcrunch.com/2014/12/03/truecaller-brings-smarter-features-to-its-phonebook-app-as-it-passes-100m-registered-users/

In general I have been able to use the browser reasonably well so far, and since I have switched to click-to-play flash, I only get crashes when I play particular videos, like the one above.
Flags: needinfo?(past)
And which video are you clicking on that caused the crash?

is that a flash video?
Posted file child-crash.log
This is a log of the crash from a debug build. The youtube video on that page is served with the HTML5 player for me.
Upgrading from OS X 10.10.1 to 10.10.2 as suggested by Jean-Yves has stopped the crashes for me.
Lodged at Apple's bugreporter as bug 19935496
Missed past update... Looks like Apple knows about it seeing that they fixed it in 10.10.2.
they'll likely get back to me with "engineering knows about it. close"
Interestingly enough, there are still some crashes in crash stats using 10.10.2 - but this crash is still relatively small volume. Last crash was build id 2015030502.
Not updated in 6 months and with 10.11 I assume this is fixed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.