Closed Bug 1120457 Opened 6 years ago Closed 6 years ago

crash in RtlEnterCriticalSection | PR_Lock | mozilla::layers::APZCTreeManager::GetTargetAPZC(mozilla::gfx::PointTyped<mozilla::ScreenPixel> const&, mozilla::layers::HitTestResult*)

Categories

(Core :: Panning and Zooming, defect)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1120252

People

(Reporter: alex_mayorga, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c59028d8-d999-4ef7-891f-6320a2150112.
=============================================================

Nightly was "insta-crashing" this morning...

Report ID 	Date Submitted
bp-551b5831-c22c-418f-bfec-2d75f2150112	1/12/2015	8:06 AM
bp-76c2c540-0566-40cc-b281-f4dbf2150112	1/12/2015	8:03 AM
bp-16156577-1830-441c-b377-1209c2150112	1/12/2015	8:03 AM
bp-c59028d8-d999-4ef7-891f-6320a2150112	1/12/2015	8:03 AM
bp-bf02b47a-9fb0-4b44-b610-cdf832150112	1/12/2015	7:54 AM
Component: General → Panning and Zooming
Product: Firefox → Core
Should be fixed by the patch on bug 1120252, but the crash stacks on this bug seem to imply that APZ is enabled on windows. If that were not the case we wouldn't have any APZCTreeManager instances at all.

Alex, was this with a clean profile? Or did you have the layers.async-pan-zoom.enabled pref flipped to true?

dvander, any ideas what might be going on here (see also bug 1120252)?
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(dvander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1120252
¡Hola Kartikaya!

I was accessing Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 trough Citrix on a Kindle Fire at the time of the crash galore. Doing so turns on some form of "touch enabled UI" on Windows it seems, don't know if related. Just checked the preference and it is set to layers.async-pan-zoom.enabled;false

I'll check tomorrow and see if the crashes are gone on the exact same setup.
Hi Alex, are you still seeing the crashes on today's nightly?
Flags: needinfo?(dvander)
(Forgot to redirect the ni in my last comment)
Flags: needinfo?(alex_mayorga)
Flags: needinfo?(alex_mayorga)
You need to log in before you can comment on or make changes to this bug.