[app-grouping][Homescreen] Unable to create a new group above the first group if the first icon is a smart collection

VERIFIED FIXED in 2.2 S4 (23jan)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: cwiiis)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe], URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8547834 [details]
logcat_20150112_CollectionIconIssue.txt

Description:
The user is able to create a new group by dragging the icon above the first group. However, when a smart collection is placed as the very first icon, the user is unable to create a new group at the top. Instead, the icon goes inside of the smart collection.
   
Repro Steps:
1) Update a Flame device to BuildID: 20150112010228.
2) Long-tap on any icon on the homescreen to enter the edit mode.
3) Drag and drop a smart collection to the top left corner of the 1st group.
4) Drag any icon to the very top of the screen to create a new group.
  
Actual:
A new group is not created at the top of the 1st group. Instead, the dragged icon goes inside the smart collection, and the icon on the homescreen stays at the same spot.
  
Expected: 
A new group is created at the top of the 1st group with the dragged icon. The icon does NOT get included in the smart collection.
  
Environmental Variables:
Device: Flame 2.2
BuildID: 20150112010228
Gaia: f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko: bb8d6034f5f2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 5/5
See attached: video clip, logcat
http://youtu.be/okJXu1HzrF4

====================================
Unable to reproduce on Flame 2.1. The homescreen does not allow to add a new group above the 1st group in v2.1.
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Assignee)

Comment 1

4 years ago
This is only the case if you hover over that collection before getting to the top of the group, but is definitely a legitimate bug, will take.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
This is not ideal but not nominating to block on this since it doesn't really break anything.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 3

4 years ago
(In reply to Chris Lord [:cwiiis] from comment #1)
> This is only the case if you hover over that collection before getting to
> the top of the group, but is definitely a legitimate bug, will take.

I was wrong about this, if the collection is the first icon, it will always go into it - but either way, the fix is very simple.

Just trying to write a test for it.
(Assignee)

Comment 4

4 years ago
Created attachment 8552415 [details] [review]
Fix creating a new group above a collection at the first position
Attachment #8552415 - Flags: review?(kgrandon)
Comment on attachment 8552415 [details] [review]
Fix creating a new group above a collection at the first position

Looks good to me. Thanks!
Attachment #8552415 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/920343e400930ec11bc6cd28becca266a77b1b34
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Note: I think you'll need to request approval for 2.2 for this bug and all other grouping bugs to get them into the 2.2 branch if that's what we want to do.)
(Assignee)

Comment 8

4 years ago
Comment on attachment 8552415 [details] [review]
Fix creating a new group above a collection at the first position

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: If the first icon is a collection, it becomes impossible to drag icons above that icon (additionally, those icons will be placed inside that collection, which is likely unexpected).
[Testing completed]: On master for a couple of days
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: None
Attachment #8552415 - Flags: approval-gaia-v2.2?
Attachment #8552415 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/e2c8ac805f74e8281025fe19cc1d1e7a27b7d48d
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S4 (23jan)
This issue has been verified as fixed on Flame 3.0

When the user drags an app to the top on the homescreen, it creates a new group instead of landing in the smart collection.

Environmental Variables:
Device: Flame 3.0(Full Flash)(KK)(319mb)
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
status-b2g-master: fixed → verified
Created attachment 8629832 [details]
verified.3gp

This bug has been verified as pass on latest build of Flame v2.2 by the STR in Comment 0. 

Results:
A new group is created at the top of the 1st group with the dragged icon. The icon does NOT get included in the smart collection.

Attachment:verified.3gp
Rate:0/15

Device: Flame v2.2 (Verified)
Build ID               20150705162505
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0214b4c1ea0
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150705.200108
Firmware Date          Sun Jul  5 20:01:20 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.