(App-grouping) Dragging the last expanded group with one row of icons causes temporary incorrect offset

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: cwiiis, Assigned: cwiiis)

Tracking

({polish})

unspecified
2.2 S8 (20mar)
All
Gonk (Firefox OS)
polish
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
If you have an expanded group at the end of a scrollable grid of icons with only one row of icons, and you scroll to the bottom, then long-press its drag handle to collapse it, the grid will be forced to scroll (as it has reduced in size) and the collapsed group will temporarily show with an incorrect offset. As soon as you move your finger again, it will be correct.

The scroll position changes are also quite janky (as the main thread isn't updated as frequently as the compositor, and even if it was, would be unlikely to keep up) - this is a separate bug though, which I will file. The fix may end up fixing both, however.
(Assignee)

Updated

3 years ago
Depends on: 1120884
(Assignee)

Updated

3 years ago
Assignee: nobody → chrislord.net
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 1

3 years ago
Created attachment 8573365 [details] [review]
[gaia] Cwiiis:bug1120882-dont-resize-during-drag > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8573365 [details] [review]
[gaia] Cwiiis:bug1120882-dont-resize-during-drag > mozilla-b2g:master

This fixes the problem by just not resizing the grid during a drag. Because the grid never gets larger during a drag and the grid is always re-rendered after a drag, we can just skip sending the resize signal during drags and rely on the render-on-finish to re-send it.
Attachment #8573365 - Flags: review?(kgrandon)
Comment on attachment 8573365 [details] [review]
[gaia] Cwiiis:bug1120882-dont-resize-during-drag > mozilla-b2g:master

This seems like there's a hard dependency on bug 1120884 which still has some questions there, so clearing review for now. Can you either roll this into that bug, or flag me after bug 1120884 has landed?
Attachment #8573365 - Flags: review?(kgrandon)
(Assignee)

Updated

3 years ago
Attachment #8573365 - Flags: review?(kgrandon)
Comment on attachment 8573365 [details] [review]
[gaia] Cwiiis:bug1120882-dont-resize-during-drag > mozilla-b2g:master

Nice and smooth, thanks!
Attachment #8573365 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 5

3 years ago
http://docs.taskcluster.net/tools/task-graph-inspector/#ONlamdpnTyWMdg2MxZX3SA

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Comment 6

3 years ago
Sorry autolander (tests are green, one unrelated intermittent that passed on a retrigger) - merged manually: https://github.com/mozilla-b2g/gaia/commit/3325c49b8ca9b238399acf045efbbb7993269d66
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Keywords: verifyme
(In reply to Chris Lord [:cwiiis] from comment #6)
> Sorry autolander (tests are green, one unrelated intermittent that passed on
> a retrigger) - merged manually:
> https://github.com/mozilla-b2g/gaia/commit/
> 3325c49b8ca9b238399acf045efbbb7993269d66

Autolander/taskcluster must be drunk. Logs are not too helpful here, I've filed bug 1142130 to track this down.
Target Milestone: --- → 2.2 S7 (6mar)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8573365 [details] [review]
[gaia] Cwiiis:bug1120882-dont-resize-during-drag > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Confusing/bad-looking behaviour when dragging the last group on the homescreen (or any group that causes the grid to shrink when scrolled to the bottom).
[Testing completed]: Manual testing and been on master for a while.
[Risk to taking this patch] (and alternatives if risky): Very low risk.
[String changes made]: None.
Attachment #8573365 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8573365 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
NI myself for following verification.
Flags: needinfo?(hcheng)
v2.2: https://github.com/mozilla-b2g/gaia/commit/587f5a7b43f626c4836032fbeff41fa3fa2dc5f1
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: 2.2 S7 (6mar) → 2.2 S8 (20mar)
Verify this bug with below builds

*2.2
Build ID               20150323162503
Gaia Revision          e54c4ed1cc188f70ddf1156534d364005dc45490
Gaia Date              2015-03-23 19:09:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7ba1778d237b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.200543
Firmware Date          Mon Mar 23 20:05:54 EDT 2015
Bootloader             L1TC000118D0

*master
Serial: f2cfccfb (State: device)
Build ID               20150323160205
Gaia Revision          8eac260ee81a8aca05770d18c5736536d44ee7a7
Gaia Date              2015-03-23 02:41:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bc85c479668a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150323.193421
Firmware Date          Mon Mar 23 19:34:34 EDT 2015
Bootloader             L1TC100118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(hcheng)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.