Closed Bug 1120886 Opened 5 years ago Closed 4 years ago

[Flame][App permission]The App Permission prompt will appear twice.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 unaffected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.1 --- affected
b2g-v2.1S --- affected
b2g-v2.2 --- unaffected

People

(Reporter: jihao, Unassigned)

References

Details

Attachments

(3 files)

Attached video twice.3gp
[1.Description]:
[Flame][v2.1][App Permission]The App Permission prompt will pop up for the second time while we tap  Share/Don't Share button after expanding More info and unchecking Remember my choice item.

Attachment: logcat_flame_0525.txt and twice.3gp
Occurrence time: 05:25

[2.Testing Steps]: 
1. Tap Rocket bar in homescreen.
2. E.me will be invoking and App Permission prompt pop up.
3. Tap More info and unchecked Remember my choice item.
4. Tap Share/Don't Share button.

[3.Expected Result]: 
The App Permission prompt shoule not pop up.

[4.Actual Result]: 
The App Permission prompt pop up again.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        1975241ac29f723479e6c60b2bf74ebed54da91a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0863fe4b75c3
Build-ID        20150112001215
Version         34.0

Flame 2.2 build:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150112010228
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached file logcat_flame_0525.txt
Hi Mike,
    This issue is still repro on Flame 2.1. Could you help with it? Thanks.
Reproduce rate:5/5
Found time:05:25
Attachment:logcat_0525.txt

Flame 2.1 build:

Build ID               20150227002636
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.035555
Firmware Date          Fri Feb 27 03:56:06 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(mlien)
Attached file logcat_0525.txt
Hi Coler, could you also help to verify if this issue can be reproduced on v2.1S?
Since this is a branch specific issue, we may only fixed on partner branch.
Flags: needinfo?(mlien) → needinfo?(liuyong)
Hi Mike,
   We can repro this bug on V2.1S(256M and 512M),hope this can help you. Thanks.

Flame2.1S_256:

Build ID               20150301161204
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150301.194157
Firmware Date          Sun Mar  1 19:42:09 EST 2015

Flame2.1S_512:

Gaia-Rev        a43d64ae01ef108aa4dcc971c770fecd8416a764
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Build-ID        20150301161204
Version         34.0
Device-Name     scx15_sp7715ea
FW-Release      4.4.2
FW-Incremental  122
FW-Date         Thu Feb  5 12:42:58 CST 2015
Flags: needinfo?(liuyong) → needinfo?(mlien)
Hi Steven, if this need to fixed on v2.1S?
Flags: needinfo?(mlien) → needinfo?(styang)
This is minor for me.
Flags: needinfo?(styang)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.