[Flame][Message]When selecting a music as Message attachment , the music control bar will display.

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Music
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Lancy(Leave from Mozilla), Assigned: mancas)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.1&v2.2][Message]Select a music as message attachment , the music control bar will display. And If you quickly tap the first tab when the control bar shows, the  music control bar will  stay on screen, or else, it will disappear quickly.
Attachment:video.mp4 & logcat_2209.txt
Found time:22:09

[2.Testing Steps]: 
1.Open message app.
2.Tap on the Compose icon.
3.Tap on Paper Clip icon.
4.Select "Music" to open select a track page.
5.Tap a music and then quickly tap the first button on music control bar.


[3.Expected Result]: 
5.Music control bar should not show on this page.

[4.Actual Result]: 
5. Music control bar will display.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        1975241ac29f723479e6c60b2bf74ebed54da91a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0863fe4b75c3
Build-ID        20150112001215
Version         34.0

Flame 2.2 build:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150112010228
Version         37.0a1

[6.Reproduction Frequency]: 
occasionally Recurrence,5/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8548123 [details]
logcat_2209.txt
(Reporter)

Comment 2

4 years ago
Created attachment 8548125 [details]
video.mp4

Comment 3

4 years ago
nom 2.2?, this page will cause attach music broken
blocking-b2g: --- → 2.2?
(Assignee)

Comment 4

4 years ago
Created attachment 8551245 [details] [review]
Proposed patch

We remove all mode classes before set the new one. This is the main cause of this issue. When we remove the |picker-mode| class, the tabs will be displayed until the new mode is set up. So, we need to preserve the tabs hidden in order to prevent this wrong behaviour. This could be reach by preserving the |picker-mode| class.

Take a look at the approach and let me know if we can reach the goal by a different way.

Thanks
Assignee: nobody → b.mcb
Attachment #8551245 - Flags: review?(squibblyflabbetydoo)

Comment 5

4 years ago
Triage comment: Please attach a video that plays. The one attached seems corrupted. It is not clear if the attaching music functionality is broken in this scenario or not. 

Thanks
Hema
Flags: needinfo?(yulan.zhu)
(Reporter)

Comment 6

4 years ago
Created attachment 8552839 [details]
New_logcat.txt

Hi Hema,
I have updated more detailed steps & video, if you have any questions please contact me.

Steps:
1.Open message app.
2.Tap on the Compose icon.
3.Tap on Paper Clip icon.
4.Select "Music" to open select a track page.
5.Select a song.
6.Go back to the track page and double-tap the lower left corner of the page.

Expected Result:
5.The black music control bar should not show in the "select a track" page.

Actual Result:
4.The black music control bar is shown on the bottom of the page.
5.The music control bar will be shown last for about 1s.
6.The music control bar is shown.

See the new attachments:New_video.MP4 & New_logcat.txt.
Occurrence time:16:31
Occurrence rate:10/10

Flame 2.1 build:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/4c28bb3be0c6
Build-ID        20150121001510
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150121.034530
FW-Date         Wed Jan 21 03:45:41 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/75a462a58d7a
Build-ID        20150121002607
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150121.040751
FW-Date         Wed Jan 21 04:08:02 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(yulan.zhu) → needinfo?(hkoka)
(Reporter)

Comment 7

4 years ago
Created attachment 8552840 [details]
New_video.MP4

Comment 8

4 years ago
Comment on attachment 8551245 [details] [review]
Proposed patch

Dominic: Can you take a look at this? You're more familiar with this code than I am. If you're busy, feel free to re-assign the review to me. Thanks!
Attachment #8551245 - Flags: review?(squibblyflabbetydoo) → review?(dkuo)

Comment 9

4 years ago
Comment on attachment 8551245 [details] [review]
Proposed patch

mancas, though your patch works but I think we can fix this issue without changing the js logic if we modify the css for the tabs |display| styles, please read my github comments, thanks.
Attachment #8551245 - Flags: review?(dkuo)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8551245 [details] [review]
Proposed patch

Dominic you're right. Fixing the issue with css is easier.

Take a look at the patch when you get a chance

Thanks!
Attachment #8551245 - Flags: review?(dkuo)

Comment 11

4 years ago
Comment on attachment 8551245 [details] [review]
Proposed patch

Thanks, now the patch looks good to me!
Attachment #8551245 - Flags: review?(dkuo) → review+

Comment 12

4 years ago
Blocking Reason: based on the latest video attached, music control bar shows up in the attach music flow leading to broken flow (user is unable to complete the task).
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(hkoka)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this when you get a chance.
status-b2g-master: --- → fixed
Flags: needinfo?(b.mcb)
Target Milestone: --- → 2.2 S6 (20feb)
(Assignee)

Comment 15

4 years ago
Comment on attachment 8551245 [details] [review]
Proposed patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): CSS
[User impact] if declined: The user can enter in a non-desirable and unresponsive situation when trying to attach a song.
[Testing completed]: No needed, the patch only contains a CSS change
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Flags: needinfo?(b.mcb)
Attachment #8551245 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8551245 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been successfully verified on latest Flame v2.2&3.0.
See attachment: verified_v2.2.mp4
Reproduce rate: 0/5

Steps:
1.Open Messages app.
2.Tap on Compose icon.
3.Tap on Paper Clip icon.
4.Select "Music" to open "Select a track" page.
5.Select a song.
6.Go back to the track page and double-tap the lower left corner of the page.
**The music control tabs don't show in the "Select a track" page as expected and only show a black bar at the bottom.

Flame 2.2 build:
Build ID               20150215002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040852
Firmware Date          Sun Feb 15 04:09:03 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150215010209
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.043133
Firmware Date          Sun Feb 15 04:31:43 EST 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
QA Whiteboard: [MGSEI-Triage+
QA Whiteboard: [MGSEI-Triage+ → [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.