Closed Bug 1120941 Opened 5 years ago Closed 5 years ago

Investigate test_ftu_skip_tour intermittent failure

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RobertC, Assigned: viorela)

Details

Attachments

(1 file)

test_ftu_skip_tour is failing intermittently on Jenkins with the following error:
Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette_test.py", line 268, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/ftu/test_ftu_skip_tour.py", line 53, in test_ftu_skip_tour
self.ftu.connect_to_wifi(ssid, psk, keymanagement)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/ftu/app.py", line 185, in connect_to_wifi
Wait(self.marionette).until(expected.element_displayed(password_element))
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.2 seconds

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/257/HTML_Report/

I was able to reproduce thee issue locally with automation. Repro rate = 1 out of 20
I have not tried to reproduce the issue manually yet.

The error requires further investigation.
QA Whiteboard: [fxosqa-auto-s8+]
I've been investigating this issue and I noticed that the test is failing because the wifi network we intend to connect to - with password enabled - is not tapped, so Enter password window is not displayed.

That's happening because we are trying to tap the wifi network before it is actually displayed on the screen. I will add a PR to wait for that network to be visible before we tap on it.
Quick fix for the intermittent failure; ahoc results: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/595/console
Attachment #8550231 - Flags: review?(jlorenzo)
Attachment #8550231 - Flags: review?(florin.strugariu)
Comment on attachment 8550231 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/27455

The wait seems appropriate here. Jenkins is green with 41 tries. r+
Attachment #8550231 - Flags: review?(jlorenzo) → review+
Attachment #8550231 - Flags: review?(florin.strugariu) → review+
Assignee: robert.chira → viorela.ioia
QA Whiteboard: [fxosqa-auto-s8+] → [fxosqa-auto-s8]
You need to log in before you can comment on or make changes to this bug.