Can not select text paragraphs on the page with mouse dragging

RESOLVED DUPLICATE of bug 82352

Status

()

RESOLVED DUPLICATE of bug 82352
17 years ago
10 years ago

People

(Reporter: jw_12, Assigned: mkaply)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

Dragging the mouse over the displayed text (main article)
does not select it for a cut & paste operation.

Reproducible: Always
Steps to Reproduce:
1. Drag mouse over the main text area
2. No paragraphs are marked as selected
3. Cut and paste into a text editor shows nothing

Actual Results:  No text is selected

Expected Results:  Text should be selcted by a mouse drag.

Comment 1

17 years ago
->selection
Assignee: asa → mjudge
Component: Browser-General → Selection
QA Contact: doronr → tpreston

Comment 2

17 years ago
I see this behavior on Win XP build 2001120303, marking new
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Is this still a bug?
WFM, Linux CVS.

Comment 4

17 years ago
Yes, I see this behavior still on win 2k build 2002010403

Comment 5

17 years ago
Build 20020214 Win2K: using the above URL, text selection is flaky.  Sometimes
is manage to select a whole paragraph, but usually the selection fails when
moving from one line to another. I think this is a BiDi problem.
(Reporter)

Comment 6

17 years ago
I doubt that it is a BiDi problem. The articles in the English version of the
site ( http://www.haaretzdaily.com/ ) show the same problem. I looked off-line
at one
of the articles, taking out the dir="ltr" tag in front of the article's body, and
the problem was still there.

Comment 7

17 years ago
I stand corrected. Somehow I've been able to miss this problem :) I think I've
also seen a bug about selection of multiple paragraphs not working if the style
changes or something..

Comment 8

17 years ago
this IS a bidi problem believe it or not.  in layout if ANY of the content has 
a BIDI setting on it it causes this behaviour.  I had this bug in the sample 
code of tables i believe once.  Debug->ViewerDemos->SimpleTables where 
selection was totally hosed in tables on that page.  If you remove the last 
example and remove anything there having to do with RTL then selection of ALL 
the tables reverts back to normal.  

The last example with the bidi setting messes up selection for the whole page.

MJ
Assignee: mjudge → mkaply
Component: Selection → BiDi Hebrew & Arabic
QA Contact: tpreston → zach

Comment 9

17 years ago
2002030716 OS/2

I have same problem on some pages:
e.g. http://bugzilla.mozilla.org/show_bug.cgi?id=118899 (tab 7 of 7)

but not on others:
e.g. http://bugzilla.mozilla.org/show_bug.cgi?id=112101 (tab 5 of 7)

I can't see any rhyme or reason to it. 
(Assignee)

Comment 10

17 years ago
It is a Bidi problem, but it also happens on UTF-8 pages.

Comment 11

17 years ago
Not NT only any more. OS needs update.
(Reporter)

Comment 12

17 years ago

*** This bug has been marked as a duplicate of 82352 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.