Intermittent leakcheck | tab process: 44330 bytes leaked (AsyncLatencyLogger, AsyncTransactionTrackersHolder, BufferRecycleBin, CipherSuiteChangeObserver, CompositableChild, ...)

RESOLVED DUPLICATE of bug 1116202

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1116202
3 years ago
2 years ago

People

(Reporter: KWierso, Assigned: mccr8)

Tracking

({intermittent-failure, leave-open})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 8 VideoFrameContainer (704 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 1 WaitableEventKernel (96 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 8 WeakReference<ImageContainer> (128 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 12 WeakReference<MessageListener> (192 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 4 ipc::MessageChannel (2048 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 3 nsLocalFile (576 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 25 nsStringBuffer (200 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 485 nsTArray_base (3880 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 3 nsThread (720 bytes)
13:45:54 WARNING - TEST-UNEXPECTED-FAIL | leakcheck | tab process: 44330 bytes leaked (AsyncLatencyLogger, AsyncTransactionTrackersHolder, BufferRecycleBin, CipherSuiteChangeObserver, CompositableChild, ...)
13:45:54 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 1025
13:45:54 INFO - |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
13:45:54 INFO - Per-Inst Leaked Total Rem Mean StdDev Total Rem Mean StdDev
13:45:54 INFO - 0 TOTAL 26 2024 252125 21 ( 2836.95 +/- 3850.27) 322803 11 ( 960.23 +/- 2349.54)
13:45:54 INFO - 7 AsyncTransactionTrackersHolder 72 72 8 1 ( 4.27 +/- 2.25) 0 0 ( 0.00 +/- 0.00)
13:45:54 INFO - 42 CondVar 40 40 8 1 ( 4.27 +/- 2.25) 0 0 ( 0.00 +/- 0.00)
13:45:54 INFO - 143 MessagePump 16 16 8 1 ( 4.27 +/- 2.25) 917 1 ( 8.10 +/- 1.31)
13:45:54 INFO - 145 Mutex 32 64 137 2 ( 62.59 +/- 33.39) 0 0 ( 0.00 +/- 0.00)
13:45:54 INFO - 159 PImageBridgeChild 736 736 1 1 ( 1.00 +/- 0.00) 0 0 ( 0.00 +/- 0.00)
13:45:54 INFO - 193 ReentrantMonitor 40 40 42 1 ( 14.53 +/- 6.49) 0 0 ( 0.00 +/- 0.00)
13:45:54 INFO - 194 RefCountedMonitor 80 80 4 1 ( 2.29 +/- 1.11) 4 1 ( 2.29 +/- 1.11)
13:45:54 INFO - 195 RefCountedTask 16 32 8 2 ( 4.50 +/- 2.14) 315 2 ( 12.29 +/- 5.87)
13:45:54 INFO - 223 StoreRef 16 48 5 3 ( 2.29 +/- 1.11) 5 3 ( 2.29 +/- 1.11)
13:45:54 INFO - 254 WaitableEventKernel 96 96 10 1 ( 4.21 +/- 2.12) 10 1 ( 4.21 +/- 2.12)
13:45:54 INFO - 256 WeakReference<MessageListener> 16 16 118 1 ( 35.36 +/- 16.95) 122 2 ( 38.22 +/- 17.94)
13:45:54 INFO - 297 ipc::MessageChannel 512 512 4 1 ( 2.29 +/- 1.11) 0 0 ( 0.00 +/- 0.00)
13:45:54 INFO - 610 nsTArray_base 8 32 69353 4 ( 8228.79 +/- 3345.77) 0 0 ( 0.00 +/- 0.00)
13:45:54 INFO - 614 nsThread 240 240 7 1 ( 3.77 +/- 1.96) 1028 1 ( 57.66 +/- 21.39)
13:45:54 INFO - nsTraceRefcnt::DumpStatistics: 671 entries
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 1 AsyncTransactionTrackersHolder (72 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 1 CondVar (40 bytes)
13:45:54 INFO - TEST-INFO | leakcheck | tab process: leaked 1 MessagePump (16 bytes)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 3

3 years ago
The leaking child process is being created during this test:
  dom/media/tests/mochitest/ipc/test_ipc.html

I can't really tell what component that should be in.  I'll put it in Video/Audio for the stream graph stuff...

Comparing the things leaked in one of these runs relative to a regular run, the additional things being leaked are:

1 AsyncLatencyLogger (72 bytes)
8 AsyncTransactionTrackersHolder (648 bytes)
15 BufferRecycleBin (840 bytes)
8 CompositableChild (1088 bytes)
16 CompositableClient (768 bytes)
2 CondVar (120 bytes)
63 ControlMessage (1008 bytes)
1 GraphDriver (88 bytes)
11 Image (1056 bytes)
8 ImageContainer (1024 bytes)
8 ImageFactory (128 bytes)
18 MediaInputPort (720 bytes)
28 MediaSegment (672 bytes)
44 MediaStream (15488 bytes)
1 MediaStreamGraph (32 bytes)
1 MediaStreamGraphImpl (416 bytes)
25 MediaStreamListener (400 bytes)
51 Mutex (1792 bytes)
8 PCompositableChild (384 bytes)
9 ReentrantMonitor (440 bytes)
22 StreamBuffer (880 bytes)
20 ThreadSharedObject (320 bytes)
66 TimeVaryingBase (66 bytes)
18 Track (432 bytes)
8 VideoFrameContainer (704 bytes)
8 WeakReference<ImageContainer> (128 bytes)
8 WeakReference<MessageListener> (192 bytes)
425 nsTArray_base (3880 bytes)
1 nsThread (720 bytes)

(ignore the bytes, they may be too high...)
Component: DOM: Content Processes → Video/Audio
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 8

3 years ago
Sheriffs, if this is too annoying, I can bump the leak threshold to 50kb on OSX or something like that tomorrow.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Andrew McCreight [:mccr8] from comment #8)
> Sheriffs, if this is too annoying, I can bump the leak threshold to 50kb on
> OSX or something like that tomorrow.

yeah seems we have now a lot of instances where this happened :(
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Andrew McCreight [:mccr8] from comment #8)
> Sheriffs, if this is too annoying, I can bump the leak threshold to 50kb on
> OSX or something like that tomorrow.

Yes, please.
Flags: needinfo?(continuation)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Depends on: 1121539
(Assignee)

Updated

3 years ago
Assignee: nobody → continuation
Keywords: leave-open
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 39

3 years ago
Created attachment 8549022 [details] [diff] [review]
Increase tab process leak threshold on OSX to paper over intermittent leak.
Attachment #8549022 - Flags: review?(jmaher)
(Assignee)

Updated

3 years ago
Flags: needinfo?(continuation)
Comment on attachment 8549022 [details] [diff] [review]
Increase tab process leak threshold on OSX to paper over intermittent leak.

Review of attachment 8549022 [details] [diff] [review]:
-----------------------------------------------------------------

bah, leaks are no fun
Attachment #8549022 - Flags: review?(jmaher) → review+
Comment hidden (Treeherder Robot)
(Assignee)

Comment 42

3 years ago
Thanks for the fast review.

https://hg.mozilla.org/integration/mozilla-inbound/rev/77c1c15a7d0d
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Depends on: 1116202
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/77c1c15a7d0d
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 60

3 years ago
Oh good, the leak has exceeded the threshold I set.  Probably somebody added more tests.  I guess I'll bump it to 100kb tomorrow.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 65

3 years ago
Created attachment 8550367 [details] [diff] [review]
Bump the leak threshold again for test_ipc.

Hopefully this will give us a little more breathing room.
Attachment #8550367 - Flags: review?(ryanvm)
Comment on attachment 8550367 [details] [diff] [review]
Bump the leak threshold again for test_ipc.

Review of attachment 8550367 [details] [diff] [review]:
-----------------------------------------------------------------

Feel free to push it CLOSED TREE to inbound if you want.
Attachment #8550367 - Flags: review?(ryanvm) → review+
(Assignee)

Comment 67

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/fb84b09d75c8
Comment hidden (Treeherder Robot)
(Reporter)

Comment 69

3 years ago
https://hg.mozilla.org/mozilla-central/rev/fb84b09d75c8
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Andrew -- Is this bug still relevant?
Flags: needinfo?(continuation)
(Assignee)

Comment 81

2 years ago
It looks like the OS X leak exception was removed in another bug, so the leak probably went away with the other mysterious media leaks.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(continuation)
Resolution: --- → DUPLICATE
Duplicate of bug: 1116202
You need to log in before you can comment on or make changes to this bug.