If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla wont start, fails completely with SEgmentation fault

RESOLVED DUPLICATE of bug 111922

Status

SeaMonkey
General
--
blocker
RESOLVED DUPLICATE of bug 111922
16 years ago
13 years ago

People

(Reporter: Kevin Maguire, Assigned: asa)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; SunOS 5.8 sun4u)
BuildID:    2001112114

I run within dd, and get the following

GNU DDD 3.2 (sparc-sun-solaris2.8), by Dorothea Lütkehaus and Andreas Zeller.
Copyright © 1995-1999 Technische Universität Braunschweig, Germany.
Copyright © 1999-2000 Universität Passau, Germany.
(no debugging symbols found)...(gdb) run
Starting program: /usr/local/mozilla/mozilla-bin 
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...[New LWP 1]
[New LWP 2]
[New LWP 3]

Program received signal SIGSEGV, Segmentation fault.
0xff1978d8 in nsComponentManagerImpl::FreeServices () from
/usr/local/mozilla/libxpcom.so
(gdb) bt
#0  0xff1978d8 in nsComponentManagerImpl::FreeServices () from
/usr/local/mozilla/libxpcom.so
#1  0xff15908c in NS_ShutdownXPCOM () from /usr/local/mozilla/libxpcom.so
#2  0x18424 in main ()
(gdb) 

Reproducible: Always
Steps to Reproduce:
1. mozilla -g
2.
3.

Actual Results:  see above

Expected Results:  a browser window?

Solaris 2.8, latest patches to yesterday applied.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 111922 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Reporter, did you build with --enable-toolkit=xlib ?
bug 111922 is Xlib-toolkit-only ...
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.