Closed Bug 1121346 Opened 5 years ago Closed 5 years ago

Improper statusbar icon color during tour

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+)

VERIFIED DUPLICATE of bug 1118361
blocking-b2g 2.2+

People

(Reporter: mikehenrty, Assigned: mancas)

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

1.) Flash phone and skip through FTE to the tour.
2.) Flash phone with FTE enabled.

Expected result:
Statusbar icons are white on the dark background.

Actual result:
Statusbar icons are dark on dark.
Barely visible statusbar icons, looks bad and tour is one of the first things the user sees.
blocking-b2g: --- → 2.2?
This issue also occurs in the email app. I believe this may occur due to a race condition. The requestAnimation that set the icon class to light or not, is been asking for the current color before the css animation starts, so the method does not detect any change in the color.

After a few test, if we wait until the css animation ends or if we let the method checks the current color, during another cycle, everything works fine. However I don't like this solution.

Alberto, you made the comparison between the current color and the previous one, didn't you? In that case, what do you think about this?
Assignee: nobody → b.mcb
Flags: needinfo?(apastor)
Attached image email_wrong_icons.png
I think this is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1118361

Apparently Bug 927349 made the color comparison trick don't work anymore.
Flags: needinfo?(apastor)
Per comment 4 this bug is a duplicate of bug 1118361
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118361
blocking-b2g: 2.2? → 2.2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.