Use web app manifest short_name below icons on homescreen

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: cwiiis, Assigned: cwiiis)

Tracking

({polish})

unspecified
2.2 S6 (20feb)
All
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
The homescreen specification available in bug 1067435 has recently been updated and shows that we should be using short_name underneath icons, when it's available.
Hi Chris, are you able to take this?
Flags: needinfo?(chrislord.net)
Assignee: nobody → bfrancis
(Assignee)

Comment 2

4 years ago
Whoops, I meant to take this a while ago - Ben, if you want to work on it, feel free to take it back - I'm assuming that assigning it to you was a mistake(?)
Assignee: bfrancis → chrislord.net
Flags: needinfo?(chrislord.net)
Created attachment 8563501 [details] [review]
[gaia] Cwiiis:bug1121466-homescreen-short-name > mozilla-b2g:master
(Assignee)

Comment 4

4 years ago
Comment on attachment 8563501 [details] [review]
[gaia] Cwiiis:bug1121466-homescreen-short-name > mozilla-b2g:master

Support short_name in manifest + marionette test
Attachment #8563501 - Flags: review?(kgrandon)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Comment on attachment 8563501 [details] [review]
[gaia] Cwiiis:bug1121466-homescreen-short-name > mozilla-b2g:master

Left a nit on github, but I think this is generally fine. Tree is currently closed, so maybe try to close/re-open the PR once gaia is open to get a try run. Thanks!
Attachment #8563501 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

4 years ago
Comment on attachment 8563501 [details] [review]
[gaia] Cwiiis:bug1121466-homescreen-short-name > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Apps with long names that have shorter names specified in their manifest will display the long name on the homescreen, possibly resulting in a confusing/bad-looking app icon subtitle.
[Testing completed]: Manually and marionette test
[Risk to taking this patch] (and alternatives if risky): Low risk, small change with automated testing
[String changes made]: None
Attachment #8563501 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8563501 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/d386821cd2371075d168fac69b871db0d88cf76e
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S6 (20feb)
No longer blocks: 1137498
Verified with below builds:

*2.2
Build ID               20150329162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.200030
Firmware Date          Sun Mar 29 20:00:41 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150329160203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.191719
Firmware Date          Sun Mar 29 19:17:28 EDT 2015
Bootloader             L1TC100118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.