Scroll bars no longer shown in 0.9.6

RESOLVED DUPLICATE of bug 109808

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 109808
17 years ago
17 years ago

People

(Reporter: Sampo Syreeni, Assigned: dbaron)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
After I switched from 0.9.5-MathML to 0.9.6-MathML, scrollers no longer show on
my site. The stylesheet used is a complex one, so I'm not entirely sure about
all the interactions, but it seems there is something very weird about all this.

The trouble seems to come from the first sheet referenced in the xhtml files,
http://www.helsinki.fi/~ssyreeni/shared/style/dc-mono/dc-mono-11-screen-xstruct.css.
That one includes two others in the same directory,
dc-mono-11-basis-xstruct.css, and dc-mono-11-visual-xstruct.css. The second
starts with a hideously long initialization rule which matches all elements. If
I remove the part which says "width:auto; background:transparent none repeat
scroll 0 0;", the scroll bar returns, but is a bit faulty. If I similarly edit
the first file, and remove part saying "display:inline" from another init rule,
I can again get the normal, working scroll bar.

As I said, this did not happen in earlier Mozilla versions. I also cannot see
 why the above settings should affect whether scroll bars are visible or not,
especially since removing only the "width:auto" and "display:inline" settings
will *not* cause the scroll bar to return.

This last point causes me to think that this might not in fact be a pure
scroller problem, but might also indicate some sort of cascade bug -- my current
sheet is a veritable monster as far as the cascade is concerned.
Is the problem here that * is matching the viewport?
(Reporter)

Comment 2

17 years ago
If there's been a change in that since 0.9.5, maybe. Still, I do not understand
what the background property has to do with it. If you have something on this
viewport stuff, pass a link, will you?
(Assignee)

Comment 3

17 years ago
I'm wondering if fantasai's patch in bug 109808 will help this.  Hopefully I'll
check it in today and maybe I'll remember to test this when I do...

Comment 4

17 years ago
Please also note Bug 112245.
(Assignee)

Comment 5

17 years ago
This should be better in tomorrow's build.

*** This bug has been marked as a duplicate of 109808 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.