Closed Bug 1121513 Opened 7 years ago Closed 7 years ago

Try out Windows builds with Visual Studio 2013 in EC2

Categories

(Release Engineering :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1124303

People

(Reporter: ted, Unassigned)

Details

Visual Studio 2013 Community is full-featured enough for our builds (I tested that it can do PGO builds) and free for open source work. We should try out building with it on EC2 and find if that's a viable path for building Windows builds in the cloud.
If the question is whether taking an ec2 windows instance, installing mozillabuild and VS2013 community allows to build firefox, then I can already give the answer: it works. I've been using such a setup for a while (although I was using Express before, but recently switched to Community)

Interestingly, instances with 8 CPUs don't build much faster than instances with 4. IIRC a build on c3.xlarge takes somewhere between 30 and 40 minutes (with no .mozconfig).
This seems to be happening in bug 1124303.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124303
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.