[Vista] Video very jittery when playing in FF 36 Beta 1

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: marcia, Assigned: marcia)

Tracking

(Blocks: 1 bug)

36 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(firefox37+ fixed, firefox38 fixed)

Details

(URL)

Seen while running: Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20150112201205 CSet: 1b26127c3323

STR:
1. Load https://www.youtube.com/watch?v=8LXxgrkcgDA and play video at any resolution.

Observe the extremely jittery playback. Video is using DASH and I am running off an ethernet connection in the office.

I also see the issue playing the video in my Win XP VM which DASH is not being used.

Graphics info from about:support/Vista machine

Graphics
--------

Adapter Description: NVIDIA GeForce 8800 GTX
Adapter Drivers: nvd3dum nvwgf2um,nvwgf2um
Adapter RAM: 768
Device ID: 0x0191
Direct2D Enabled: true
DirectWrite Enabled: true (7.0.6002.23200)
Driver Date: 10-2-2012
Driver Version: 9.18.13.697
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 039c10de
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce 8800 GTX Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Will grab some logging if that is useful.
Blocks: 778617
ni on Chris as I called out this bug in the standup. The video in the URL field was the one I had difficultly playing on Vista.
Flags: needinfo?(cpearce)
What does "jittery playback" mean? I don't get anything like what I'd call jittery playback in my VM, but of course my VM doesn't have hardware accelerated decoding, and the bug may be in your graphics cards' drivers... If you set the pref media.windows-media-foundation.use-dxva to false do you get different behaviour?
Flags: needinfo?(mozillamarcia.knous)
I will try out the pref - when I play the video in Comment 0 in the highest resolution, it stops and starts constantly with no spinner - almost as if at times it is in slow motion.

Here is my graphic info from about:support in this machine:

Application Basics
------------------

Name: Firefox
Version: 36.0
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0
Multiprocess Windows: 0/1

Extensions
----------

Name: Microsoft .NET Framework Assistant
Version: 0.0.0
Enabled: false
ID: {20a82645-c095-46ed-80e3-08825760534b}

Name: Norton Identity Safe Toolbar
Version: 2013.2.2.3
Enabled: false
ID: {F04D2D30-776C-4d02-8627-8E4385ECA58D}

Graphics
--------

Adapter Description: NVIDIA GeForce 8800 GTX
Adapter Drivers: nvd3dum nvwgf2um,nvwgf2um
Adapter RAM: 768
Device ID: 0x0191
Direct2D Enabled: true
DirectWrite Enabled: true (7.0.6002.23200)
Driver Date: 10-2-2012
Driver Version: 9.18.13.697
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 039c10de
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce 8800 GTX Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(mozillamarcia.knous)
marcia to check if audio is keeping up with the video in this situation.
Flags: needinfo?(mozillamarcia.knous)
also during triage we mentioned we would revisit this bug after some more investigation.
Flags: needinfo?(mozillamarcia.knous)
Yesterday I tried to see if the audio was syncing up, but it turns out the audio driver on this machine seems a bit messed up. So it makes it a bit difficult to ascertain if the audio is keeping up in this case.

Comment 7

4 years ago
Marcia, I think the last we talked you were going to look into reproducing this. Sounds like it's not a clear blocker for 36. Do just leave it in unprioritized for now?

Comment 8

4 years ago
Marcia is going to retest this on Aurora.

Updated

4 years ago
Priority: -- → P1
Flags: needinfo?(mozillamarcia.knous)
Assignee: nobody → mozillamarcia.knous
I will check this again tomorrow - after playing a series of videos on the same machine using Aurora, I haven't yet seen the same behavior.
Tracking all MSE P1 bugs for Firefox 37.
status-firefox37: --- → affected
status-firefox38: --- → affected
tracking-firefox37: --- → +

Comment 11

4 years ago
> Driver Date: 10-2-2012
> Driver Version: 9.18.13.697

Have you also tried with Jul 29, 2014 GeForce 340.52?

Comment 12

4 years ago
> Driver Date: 10-2-2012
> Driver Version: 9.18.13.697

I forgot to update that 341.44 are available. Have you tried to repro with that version?
No longer seeing the issue on the same machine. I updated the drivers and am running Mozilla/5.0 (Windows NT 6.0; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150309191715 CSet: 8065aad58fc2.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → WORKSFORME
status-firefox37: affected → fixed
status-firefox38: affected → fixed
Flags: needinfo?(cpearce)
You need to log in before you can comment on or make changes to this bug.