[Contacts] - Contact pick option (select from multiple contact methods) has repeat options when tapping on a contact multiple times before the list loads.

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: mancas)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8549192 [details]
logcat_20150114_1408.txt

Description:
When composing a message in SMS or Email apps and adding a contact you will be taken to your contact list. When you select a contact that has multiple contact methods such as multiple numbers or a number and email you will be taken to a picker-list with the options. If you tap on the contact entry to quickly (or if it is taking a long time to load; then not-so-quickly) the list (including the cancel option) will be repeated multiple times. 

Notes: While 'Spamming the contact selection' is a part of the repro of this bug it was actually found through 'normal usage'. I had several different apps going and the contacts was loading VERY slowly (plus, i probably have higher than average contact #'s) but I had hit a contact and after a few seconds, thinking the device did not register my selection I tapped the contact again and eventually loaded a list with the choices repeated.

Repro Steps:
1) Update a Flame to 20150114010205
2) Open SMS app
3) Select Compose new SMS
4) Click + to add a contact
5) As soon as a contact (one with multiple contact methods) is loaded tap on it a few times

Actual:
The pick menu has the contact choices repeated multiple times

Expected:
Each choice will only be present once

Environmental Variables:
Device: Flame Master
Build ID: 20150114010205
Gaia: e2a0f7c311119d4a8e160bdfb9e28a0e61a180fc
Gecko: 63006936ab99
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (Master)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 6/8
See attached: logcat, Video: http://youtu.be/gaiZA-Jkh_o

-----------------------------------------------------------------------------------------------
This also occurs on 2.2 (V18d-1), 2.2 (V18d), and 2.1 (V18d-1)


Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150114002502
Gaia: 7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko: 748b20315f75
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a2 
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150114002502
Gaia: 7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko: 748b20315f75
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a2
Firmware Version: V18d
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (KK - Nightly - Full-Flashed)
Build ID: 20150113001255
Gaia: 836e6d74cb8b7016df555f85445893b3ff9aac12
Gecko: 074f79a929d2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
------------------------------------------------------------------------------------
This issue does NOT repro on 2.0 
Actual Results - The picker list has a different design (justified on the top instead of the bottom and a different look)  (Probably not a regression but something introduced with the re-design of the picker menu)

Device: Flame 2.0 (KK - Nightly - Full-Flashed)
Build ID: 20150113000203
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: c6fd5db59e0e
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 32.0 (2.0)
Firmware Version: V18d-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Not going to nominate this, edge case that doesn't break functionality although creates a poor UX.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Definitely a poor experience.

Probably introduced when we created the send to email via sms from contacts.
blocking-b2g: --- → backlog
After checking the video for a second time, I'm nominating as a blocker since the effect is really ugly.
blocking-b2g: backlog → 2.2?
This is not related with send to e-mail functionality. You can add a contact with two e-mails and reproduce this issue when selecting the destinatary for an e-mail from E-Mail app.
triage: major issue which we should block
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 6

4 years ago
Created attachment 8554511 [details] [review]
Proposed patch

Hey Francisco, could you review the patch when you get a chance? We should remove the previous content of the action_menu before insert more content.

Thanks!
Assignee: nobody → b.mcb
Attachment #8554511 - Flags: review?(francisco)
Comment on attachment 8554511 [details] [review]
Proposed patch

Great!

Codewise looks perfect to me, can we have an integration test to try this?
Attachment #8554511 - Flags: review?(francisco)

Updated

4 years ago
Target Milestone: --- → 2.2 S5 (6feb)
(Assignee)

Comment 8

4 years ago
Comment on attachment 8554511 [details] [review]
Proposed patch

Francisco I've added the integration test. Could you review the patch when you get a chance?

Thanks!
Attachment #8554511 - Flags: review?(francisco)
Comment on attachment 8554511 [details] [review]
Proposed patch

Great job!

r=me
Flags: needinfo?(francisco)
Attachment #8554511 - Flags: review?(francisco) → review+
Needed to relaunch some test, will merge once we get a green build.
Flags: needinfo?(francisco)
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/f9e5cf8bc48eb57452a76f43058e23cabb4adb22
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Hi Manuel,

can you ask for approval 2.2?
Flags: needinfo?(b.mcb)

Updated

4 years ago
status-b2g-master: affected → fixed
(Assignee)

Comment 13

4 years ago
Comment on attachment 8554511 [details] [review]
Proposed patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Action Menu
[User impact] if declined: The user can touch multiple times a contact and the buttons to select the email, will be duplicated
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Attachment #8554511 - Flags: approval-gaia-v2.2?
Flags: needinfo?(b.mcb)

Updated

4 years ago
Attachment #8554511 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: Each option is only shown once if the contact is repeatedly tapped.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150506010204
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: ba44099cbd07
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150506002501
Gaia: 772a9491909abd02dc67278dd453746e2dd358a8
Gecko: 3af6a0a79227
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.