(App-grouping) Tapping blank space in collapsed group should not expand that group in both normal and edit modes

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: hcheng, Assigned: cwiiis)

Tracking

({polish})

unspecified
2.2 S6 (20feb)
All
Gonk (Firefox OS)
polish
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

*Description:
When tap blank space at a collapsed group, that group should be expanded.

*2.2 UX Spec page 10:
https://mozilla.app.box.com/s/44utizl9oz4eupyu3fuu/1/2709316676/24961186345/1

*Env:
Build ID               20150114002502
Gaia Revision          7c5b27cad370db377b18a742d3f3fdb0070e899f
Gaia Date              2015-01-12 17:32:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150114.040029
Firmware Date          Wed Jan 14 04:00:40 EST 2015
Bootloader             L1TC000118D0
It works fine at Homescreen edit mode, but does not work at Homescreen normal mode.
Blocks: 1067435
blocking-b2g: --- → 2.2?
Flags: needinfo?(chrislord.net)
Whiteboard: [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Flags: needinfo?(chrislord.net)
Not holding the release for it.
blocking-b2g: 2.2? → ---
(Assignee)

Comment 3

4 years ago
The bug here is that this doesn't happen in non-edit mode, retitling to be clear.

This is tricky because it's the verticalhome app that provides the context menu for the homescreen, but the grid that handles expanding/collapsing groups. We can probably handle this in verticalhome by getting the nearest icon to the tap position, finding its group and manually expanding it.
Summary: (App-grouping) Tapping blank space at collapsed group should expand that group → (App-grouping) Tapping blank space in collapsed group should expand that group in both normal and edit modes
(Assignee)

Comment 4

4 years ago
So yeah, failing to get this done for some reason - I decided to keep it in GaiaGrid as it's kind of awkward splitting the logic outside of it, but my initial run at it doesn't work... Will come back to it later.

https://github.com/Cwiiis/gaia/tree/bug1121858-tap-blank-expand-group
(Assignee)

Comment 5

4 years ago
(In reply to Chris Lord [:cwiiis] from comment #4)
> So yeah, failing to get this done for some reason - I decided to keep it in
> GaiaGrid as it's kind of awkward splitting the logic outside of it, but my
> initial run at it doesn't work... Will come back to it later.
> 
> https://github.com/Cwiiis/gaia/tree/bug1121858-tap-blank-expand-group

Realised this morning that this should work on top of bug 1121149, which has landed. Will test in a bit.
Depends on: 1121149
(Assignee)

Comment 6

4 years ago
I'm at a loss as to why this isn't working. Just seems I don't get the events I expect, despite the element's box being correct and showing up as expected in WebIDE. Don't want to waste too much time on this, so leaving for now... My branch is up-to-date with a solution that I think should work, but doesn't - perhaps someone else will pick it up later.
Assignee: chrislord.net → nobody
Status: ASSIGNED → NEW
Keywords: polish

Comment 7

4 years ago
UX Recommendation: 
The expand/collapse toggle button is the only way to trigger the expand or collapse group functionality. A single tap on a blank or empty space will not trigger expand group. Collapsing and expanding groups works the same way in edit mode as on the home screen. 

This means, removing the functionality from Edit Mode (where it is currently enabled). UX Reason: were the user to experience it in Edit Mode, it raises expectations of similar functionality on the home screen.

NI'ing Chris to remove 'tapping on a collapsed group in Edit Mode expands group'. 

[ux spec v1.8 to be updated this week and posted to Meta Bug 1067435]
Flags: needinfo?(chrislord.net)
(In reply to katieC from comment #7)
> UX Recommendation: 
> The expand/collapse toggle button is the only way to trigger the expand or
> collapse group functionality. A single tap on a blank or empty space will
> not trigger expand group. Collapsing and expanding groups works the same way
> in edit mode as on the home screen. 
> 
> This means, removing the functionality from Edit Mode (where it is currently
> enabled). UX Reason: were the user to experience it in Edit Mode, it raises
> expectations of similar functionality on the home screen.
> 
> NI'ing Chris to remove 'tapping on a collapsed group in Edit Mode expands
> group'. 
> 
> [ux spec v1.8 to be updated this week and posted to Meta Bug 1067435]

According to UX spec v1.8 [1], modify this bug to disable "tapping on a collapsed group" in edit mode, and nominate it to block v2.2.


[1] https://bug1067435.bugzilla.mozilla.org/attachment.cgi?id=8558169
blocking-b2g: --- → 2.2?
Summary: (App-grouping) Tapping blank space in collapsed group should expand that group in both normal and edit modes → (App-grouping) Tapping blank space in collapsed group should not expand that group in both normal and edit modes
not a blocker, polish bug that ux confirmed not blocking
blocking-b2g: 2.2? → backlog
(Assignee)

Updated

4 years ago
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Flags: needinfo?(chrislord.net)
Created attachment 8563465 [details] [review]
[gaia] Cwiiis:bug1121858-only-toggle-should-toggle > mozilla-b2g:master
(Assignee)

Comment 11

4 years ago
Comment on attachment 8563465 [details] [review]
[gaia] Cwiiis:bug1121858-only-toggle-should-toggle > mozilla-b2g:master

There are already expand/collapse tests, and I don't think they tested being able to expand by tapping anywhere, so no need to change tests. (I may be wrong, in which case I'll fix any failing tests when tests come back online)
Attachment #8563465 - Flags: review?(kgrandon)
Comment on attachment 8563465 [details] [review]
[gaia] Cwiiis:bug1121858-only-toggle-should-toggle > mozilla-b2g:master

Thanks!
Attachment #8563465 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/28179

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

4 years ago
Comment on attachment 8563465 [details] [review]
[gaia] Cwiiis:bug1121858-only-toggle-should-toggle > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Slightly inconsistent behaviour when expanding groups in edit mode.
[Testing completed]: Manually, and covered by marionette tests.
[Risk to taking this patch] (and alternatives if risky): Low risk, tiny change.
[String changes made]: None
Attachment #8563465 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8563465 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/299c29701c9c9f64389ddf25c655879b8df2130a
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S6 (20feb)
verified fixed in v2.2 at below build

Build ID               20150223002503
Gaia Revision          389542b71c89253c0d176d3b0bfb54e275c19bf1
Gaia Date              2015-02-22 20:32:37
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9fd3441c8983
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150223.035603
Firmware Date          Mon Feb 23 03:56:13 EST 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: fixed → verified
*master build 

Build ID               20150225160227
Gaia Revision          cc235a867161e0000ea55a4f009b3be19021f066
Gaia Date              2015-02-25 05:01:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6608e0605dfc
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.192909
Firmware Date          Wed Feb 25 19:29:21 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-master: fixed → verified
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.