[Flame][Camera]The minimized calling bar will partially cover the 3 camera setting icons at top of view finder.

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: SandKing, Assigned: alive)

Tracking

unspecified
2.2 S5 (6feb)
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 verified, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8549493 [details]
Bug video: 1511.MP4

[1.Description]:
[Flame][v2.1&v2.2][Camera]After you enter camera from lockscreen with a call processing in background, the calling bar will partially cover the 3 camera setting icons at top of view finder.
See log:"logcat_1511.txt"
Bug video:"1511.MP4"
Found Time:15:11

[2.Testing Steps]: 
1. Launch Phone, and create a conversation.
2. Press "Home" button.
3. Press "Power" key to suspend device.
4. Press "Power" key again.
5. On lockscreen page slide the slider to the left, toward the camera icon.
6. Wait device load to Camera page.



[3.Expected Result]: 
6. The minimized calling bar should be hidden when you launch camera from Lockscreen page

[4.Actual Result]: 
6. The minimized calling bar will partially cover the 3 camera setting icons at top of view finder.

[5.Reproduction build]: 
Flame 2.1:
Gaia-Rev        6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6600eba54256
Build-ID        20150114001300
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.035135
FW-Date         Wed Jan 14 03:51:46 EST 2015
Bootloader      L1TC000118D0

Flame 2.2
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150114002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.040029
FW-Date         Wed Jan 14 04:00:40 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8549495 [details]
Bug log: logcat_1511.txt
Created attachment 8551108 [details]
2015-01-18-18-11-38.png

Functionality okay but need UI improvement.
Nom for 2.2? for bad UI.
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Gaia::System]

Comment 4

3 years ago
Blocking Reason: Bad User experience with diminished access to camera functions on HUD

Wilson, please take an initial look and route accordingly. thanks!
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(wilsonpage)
IMO there are several options:

A. Call status bar is never shown in fullscreen apps (like Camera and Gallery)
B. App's could use some kind of hook/event to allow them to adapt/reposition UI based on the call status bar.
C. Status bar could be swipable up/down manually by the user to give them the ability to move it when it's obscuring content.

Looping in world renowned :amylee to advise...
Flags: needinfo?(wilsonpage) → needinfo?(amlee)

Comment 6

3 years ago
(In reply to Wilson Page [:wilsonpage] from comment #5)
> IMO there are several options:
> 
> A. Call status bar is never shown in fullscreen apps (like Camera and
> Gallery)
> B. App's could use some kind of hook/event to allow them to adapt/reposition
> UI based on the call status bar.
> C. Status bar could be swipable up/down manually by the user to give them
> the ability to move it when it's obscuring content.
> 
> Looping in world renowned :amylee to advise...

Ha, thanks Wilson. Taking photos while a call is in progress seems to be an edge case. I would opt for either option A or C but I will get Tif to have the final say from UX. NI'ing Tiff.
Flags: needinfo?(amlee) → needinfo?(tshakespeare)
Taking calls during a call is definitely an edge case.

I agree with Amy about either option A or C. A is going probably going to be easier as C would require some further design and discussion to make sure it wouldn't interfere with the notification interaction.
Flags: needinfo?(tshakespeare)
Moving this from 'Camera' to 'System' and NI :gmarty (worked on status bar) to find a better home for this.
Component: Gaia::Camera → Gaia::System
Flags: needinfo?(gmarty)
Flags: needinfo?(gmarty)
Whiteboard: [systemsfe]
Alive, this looks like an attention screen issue. Any idea what's going on?
Component: Gaia::System → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
This is a missing part from bug 927862.
The spec of the new attention window said we should always show attention toaster in lockscreen but didn't mention that what should happen if opening the secure camera from lockscreen.

What we could do here is:
Use Service.query('getTopMostWindow') in attention_toaster.js and in addition listen to secure-appopened/secureappclosed to update the toaster state.
Assignee: nobody → alive
Flags: needinfo?(alive)

Comment 11

3 years ago
Created attachment 8554460 [details] [review]
[PullReq] alivedise:bugzilla/1121884/toggle-toaster-on-secure-app to mozilla-b2g:master
Attachment #8554460 - Flags: review?(etienne)
Comment on attachment 8554460 [details] [review]
[PullReq] alivedise:bugzilla/1121884/toggle-toaster-on-secure-app to mozilla-b2g:master

nice!
Attachment #8554460 - Flags: review?(etienne) → review+
https://github.com/mozilla-b2g/gaia/commit/e46c388920f4d102581efb9365c22b02820b3003
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: --- → fixed
Resolution: --- → FIXED
Comment on attachment 8554460 [details] [review]
[PullReq] alivedise:bugzilla/1121884/toggle-toaster-on-secure-app to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Not a regression exactly; bug 927862 makes this problem easier to note because now attention toaster will timeout and hide itself but before v2.1 the toaster always was there even there was a fullscreen app. The problem is we didn't think of fullscreen app on top of lockscreen case but only considered the toaster on lockscreen should be consistent opened because the user is not able to access utility tray in lockscreen mode.
[User impact] if declined:
User is not able to interact with secure camera (camera launched with passcode enabled on lockscreen)
[Testing completed]: All green
[Risk to taking this patch] (and alternatives if risky):
Riskless because it is just adding one more event(secure app open/close) into the transition state machine.
[String changes made]: NaN
Attachment #8554460 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Keywords: verifyme

Updated

3 years ago
Attachment #8554460 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/1354b3c1d5fdd4cc8f0457701ff14dcfae3ceb04
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S5 (6feb)
Created attachment 8556999 [details]
Verify_video.MP4
The problem is verified not happen on latest Flame 2.1 & 2.2 & 3.0 build.

Steps:
1. Launch Phone, and create a conversation.
2. Press "Home" button.
3. Press "Power" key to suspend device.
4. Press "Power" key again.
5. On lockscreen page slide the slider to the left, toward the camera icon.
6. Wait device load to Camera page.

  
Actual:
The minimized calling bar will be hidden when you launch camera from Lockscreen page.
Fail rate:0/5
See attachment:Verify_video.MP4

Flame 2.1 version:
Gaia-Rev        9df43e6e696da43b6a1433283dc5b155987747bc
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/095a46f32cd4
Build-ID        20150129003733
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.041104
FW-Date         Thu Jan 29 04:11:14 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 version:
Gaia-Rev        6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Build-ID        20150129003432
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.042943
FW-Date         Thu Jan 29 04:29:53 EST 2015
Bootloader      L1TC000118D0

Flame 3.0 version: 
Gaia-Rev 9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57 
Gecko-Rev https://hg.mozilla.org/mozilla-central/rev/6bfc0e1c4b29 
Build-ID 20150129010239 
Version 38.0a1 
Device-Name flame 
FW-Release 4.4.2 
FW-Incremental eng.cltbld.20150129.043711 
FW-Date Thu Jan 29 04:37:21 EST 2015 
Bootloader L1TC000118D0
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Keywords: verifyme
status-b2g-v2.1: affected → verified
Per Comment 17
Status: RESOLVED → VERIFIED

Comment 19

3 years ago
Hi, Lance,

I saw the reproduction steps you noted on comment 0 is different from the video show (comment 0)
If I follow the reproduction steps of video (comment 0), I still can reproduce this bug.
Could you please file a new bug?
Thanks.
Status: VERIFIED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-b2g-v2.1: verified → affected
Flags: needinfo?(liuke)

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.1: affected → verified

Comment 20

3 years ago
(In reply to William Hsu [:whsu] from comment #19)
> Hi, Lance,
> 
> I saw the reproduction steps you noted on comment 0 is different from the
> video show (comment 0)
> If I follow the reproduction steps of video (comment 0), I still can
> reproduce this bug.
> Could you please file a new bug?
> Thanks.

My bad. I NI the wrong person.
I would like to NI "SandKing" since he submitted this bug.
Flags: needinfo?(liuke) → needinfo?(wangxin)
(Reporter)

Comment 21

3 years ago
Hi William,
In the vidoe attached in Comment 0, make a phone call and then tap Camera on Homescreen first, which is to prove that this problem does not exist when you open camera from Home view. This is only for reference. The real bug is like the STR description in Comment 0, or you can refer to Lance verification result in Comment17. And I’ve just verified this issue has already been fixed in lasted Flame 2.1 and Flame2.2.

Flame2.1 bulid:
Gaia-Rev        63f291df9b9ad8498fb8fc7fb8bf070524406a5c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/70b8982a523d
Build-ID        20150201001213
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.035104
FW-Date         Sun Feb  1 03:51:15 EST 2015
Bootloader      L1TC000118D0

Flame2.2 build:
Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f7414413e3a5
Build-ID        20150201002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.043120
FW-Date         Sun Feb  1 04:31:31 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(wangxin) → needinfo?(whsu)

Comment 22

3 years ago
(In reply to SandKing from comment #21)
> Hi William,
> In the vidoe attached in Comment 0, make a phone call and then tap Camera on
> Homescreen first, which is to prove that this problem does not exist when
> you open camera from Home view. This is only for reference. The real bug is
> like the STR description in Comment 0, or you can refer to Lance
> verification result in Comment17. And I’ve just verified this issue has
> already been fixed in lasted Flame 2.1 and Flame2.2.
> 

Oh! I see.
Understanding from your demo video (comment 0 - 1511.MP4), the notification bar automatically dismissed after 3 seconds.
It doesn't stay resident on the top of the screen.
Okay. I think it is a acceptable behavior.
No more questions.
Many thanks.
Flags: needinfo?(whsu)
You need to log in before you can comment on or make changes to this bug.