Closed Bug 1121917 Opened 5 years ago Closed 5 years ago

[Contacts] Contact details wrong view when special characters are present

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S4 (23jan)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: noemi, Assigned: jmcf)

References

Details

Attachments

(5 files, 1 obsolete file)

Attached image Contact_Details_View
Description:
Contact details wrong view and unexpected vcard file name within Messaging app when special characters are present in the contact


STRs:
1- Create a contact including special characters (Name: Pruebá; Last Name: Eñe). Please see "Contact_Details-View.png" and "Contacts_List.png" files attached.
2- Go to Messaging app and try to share that contact via MMS. Once the .vcf file is attached, the name of that file ("Prueba_Ene") is not the expected one (Pruebá_Eñe). Please see "Message_Thread.png" file attached.
3- Being in the message thread, click on the contact vcard
4- Contact details screen is opened, the Name and the Last Name of the contact are not the expected ones, please see "Contact_Details_View_From_Messaging.png" file attached


Environmental Variables:
Device: flame-kk (Build Number 142)
BuildID: 20150115065156
Gecko: c815fdc
Gaia-9a85671
Version: 38.0a1


Repro frequency: 100%
Attached image Contacts_List
Attached image Message_Thread
Attached file PR to GH (obsolete) —
Attachment #8549549 - Flags: review?(francisco)
Assignee: nobody → jmcf
blocking-b2g: --- → 2.2?
QA Contact: jlorenzo
Comment on attachment 8549549 [details] [review]
PR to GH

Can we have test for the output generated in ContactToVcardBlob ?
Attachment #8549549 - Flags: review?(francisco)
Triage: New feature broken which will impact all languages that use accented characters.
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8549549 [details] [review]
PR to GH

comments addressed and tests added

thanks!
Attachment #8549549 - Flags: review?(francisco)
Target Milestone: --- → 2.2 S4 (23jan)
Comment on attachment 8549549 [details] [review]
PR to GH

Perfect, thanks a lot for adding the test.

Not granting the approval since the unit test is failing in gaia-try.
Attachment #8549549 - Flags: review?(francisco)
Attached file GH PR
Attachment #8551175 - Flags: review?(francisco)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #8)
> Comment on attachment 8549549 [details] [review]
> PR to GH
> 
> Perfect, thanks a lot for adding the test.
> 
> Not granting the approval since the unit test is failing in gaia-try.

It seems you checked a previous execution of gaia-try. I have changed the PR just to force a gaia-try relaunch but no luck till the moment. Once the ga-atry job finishes I will ping you on IRC

thanks
Attachment #8549549 - Attachment is obsolete: true
Comment on attachment 8551175 [details] [review]
GH PR

Thanks Jose, please merge once we have gaia-try green.
Attachment #8551175 - Flags: review?(francisco) → review+
https://github.com/mozilla-b2g/gaia/commit/00fd3b640acefdfd886a113408f0fdb5fde1b516
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8551175 [details] [review]
GH PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): vcard attachments / sharing
[User impact] if declined: Very high, special characters in non-English languages can appear as corrupted and the vcards received by users will be useless. 
[Testing completed]: Yes, unit tests provided
[Risk to taking this patch] (and alternatives if risky): nearly-zero-risk patch
[String changes made]: none
Attachment #8551175 - Flags: approval-gaia-v2.2?
Attachment #8551175 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
On the latest Nightly Flame 3.0 and 2.2 builds, the contacts details view when adding through the messages app does not corrupt special characters.  However the filename as expected according to step 2 of the description is still incorrect.

Is this the expected results from your changes Jose?

Environmental Variables:
Device: Flame 3.0
BuildID: 20150302010223
Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gecko: eea6188b9b05
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150302002504
Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gecko: 27ab8aa34201
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
Flags: needinfo?(jmcf)
Flags: needinfo?(ktucker)
(In reply to Jayme Mercado [:JMercado] from comment #15)
> On the latest Nightly Flame 3.0 and 2.2 builds, the contacts details view
> when adding through the messages app does not corrupt special characters. 
> However the filename as expected according to step 2 of the description is
> still incorrect.
> 
> Is this the expected results from your changes Jose?

Yes, we did not fix anything related to the filename, only to the content. 

> 
> Environmental Variables:
> Device: Flame 3.0
> BuildID: 20150302010223
> Gaia: f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
> Gecko: eea6188b9b05
> Gonk: e7c90613521145db090dd24147afd5ceb5703190
> Version: 39.0a1 (3.0) 
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
> 
> Environmental Variables:
> Device: Flame 2.2
> BuildID: 20150302002504
> Gaia: 77609916ca5ab721150fab2b7bc5c37f43ee3a5a
> Gecko: 27ab8aa34201
> Gonk: e7c90613521145db090dd24147afd5ceb5703190
> Version: 37.0 (2.2) 
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(jmcf)
(In reply to Jose Manuel Cantera from comment #16)
> (In reply to Jayme Mercado [:JMercado] from comment #15)
> > On the latest Nightly Flame 3.0 and 2.2 builds, the contacts details view
> > when adding through the messages app does not corrupt special characters. 
> > However the filename as expected according to step 2 of the description is
> > still incorrect.
> > 
> > Is this the expected results from your changes Jose?
> 
> Yes, we did not fix anything related to the filename, only to the content. 
> 

A follow up Bug 1138826 has been opened to track it. Thanks!
See Also: → 1138826
Setting the flags for this issue as verified per comment 16 and my testing yesterday.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.