Closed Bug 1122025 Opened 5 years ago Closed 5 years ago

Bluetoothd correctness fixes

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S4 (23jan)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: tzimmermann, Assigned: tzimmermann)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Attached file Github tree (obsolete) —
Hi Shawn,

The patch set depends on bug 1119746. I was hoping you could already give me feedback on the patches, so that the 'official' final review proceeds quickly after bug 1119746 landed.

Some remarks:

The best text I know of on writing daemon start-up code is in 'The Linux Programming Interface', Chapter 37. An alternative is available at [1].

The overhead of the wakelocks is minimal. I switched on and off Bluetooth and it only took ~20 wakelocks, each for only a few milliseconds.

[1] http://www.netzmafia.de/skripten/unix/linux-daemon-howto.html
Attachment #8549664 - Flags: feedback?(shuang)
This patch set improves reliability of the Bluetooth daemon, so I'd like to land it in 2.2. I think the risk is minimal, and the changes can be rolled back easily.
blocking-b2g: --- → 2.2?
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #2)
> This patch set improves reliability of the Bluetooth daemon, so I'd like to
> land it in 2.2. I think the risk is minimal, and the changes can be rolled
> back easily.

True. I think overall the patch set is low risk and it shall improve reliability especially avoid unexpected behaviors when system goes into sleep mode. We shall have this patch set no matter what.
Hi Howie,
We shall nominate this bug to 2.2 feature+.
Flags: needinfo?(hochang)
blocking-b2g: 2.2? → ---
feature-b2g: --- → 2.2+
Flags: needinfo?(hochang)
Target Milestone: --- → 2.2 S4 (23jan)
Attached file Github pull request
This pull request contains the original patch set with the fixed order of the header files in patch 4.

The other patches belong to bug 1119746. I'll remove them, once bug 1119746 landed.
Attachment #8549664 - Attachment is obsolete: true
Attachment #8551242 - Flags: review?(shuang)
Comment on attachment 8551242 [details]
Github pull request

Updated Gihub pull request

  - rebased pull request on bug 1119746, no code changes
Comment on attachment 8551242 [details]
Github pull request

It looks good to me.
Attachment #8551242 - Flags: review?(shuang) → review+
Thanks!
Keywords: checkin-needed
Comment on attachment 8551242 [details]
Github pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): No
User impact if declined: We need to improve stability for bluetoothd in v2.2
Testing completed: Test if wake lock can be properly released
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch:None
Attachment #8551242 - Flags: approval-mozilla-b2g37?
Attachment #8551242 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.