Closed Bug 1122036 Opened 5 years ago Closed 2 years ago

getUserMedia() fails but doesn't call failure callback when called from a Panel in versions > 34.0

Categories

(Add-on SDK Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: keithlarrimore, Unassigned)

References

()

Details

Attachments

(1 file)

11.03 KB, application/x-xpinstall
Details
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127111021

Steps to reproduce:

navigator.mozGetUserMedia({ audio: true, video: false }, function(m) { console.debug('gum success') }, function(e) { console.debug('gum error') })

or any other way to call getUserMedia from an addon's Panel


Actual results:

Neither the success function or the failure function is called.  In the Developer Edition 36.0a2 there is an error "mm is undefined" thrown on line 409 of webrtcUI.jsm.  The line contains this:

mm.sendAsyncMessage("webrtc:Allow", {callID: aRequest.callID,
                                                        windowID: aRequest.windowID,
                                                        devices: allowedDevices});




Expected results:

The success functiion should be called or at very least the failure function should be.
Can you provide a test add-on?
Component: Untriaged → General
Flags: needinfo?(keithlarrimore)
Product: Firefox → Add-on SDK
Version: 35 Branch → unspecified
i cre(In reply to :Gijs Kruitbosch from comment #1)
> Can you provide a test add-on?

I created a test addon that will reproduce the issue at https://github.com/klarrimore/firefox-bug-1122036-addon

I packaged an xpi and put it in the project and i'll add it as an attachment here too.

The addon test should work without an issue on 34.0 but not on 35+
Flags: needinfo?(keithlarrimore)
Attached file addon to reproduce
should work fine in 34 but not 35+
From a very quick look, this seems similar to bug 1007817... and as far as I know getUserMedia never worked in Add-on SDK panels (due to bug 1007817), so I'm surprised you say it worked fine in 34.
Yeah, I had run into https://bugzilla.mozilla.org/show_bug.cgi?id=1007817 but was able to get it to work by making sure to always open the Panel before any getUserMedia() request.
OS: Linux → All
Hardware: x86_64 → All
Can you share your Fix please.
https://bugzilla.mozilla.org/show_bug.cgi?id=1399562
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.