MixCloud player does not work in Firefox for Android

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: hallvors)

Tracking

({reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Currently on MixCloud, their player does not seem to work in Firefox for Android.

To replicate, attempt to play

http://www.mixcloud.com/JodyWisternoff/intensified-on-frisky-radio-jan-2015/

Player: https://media-mix.netdna-ssl.com/media/js2/mobile_web_js.2c80a98008edba2047c5dbc0e7e38cb4.js

Possible feature detection failure? e.g,

return e.navigatorType && e.navigatorType("audio/mpeg").replace(/no/, "") && e.navigatorType('audio/mp4; codecs="mp4a.40.2"').replace(/no/, "")

--
Nightly (01/15)
Motorola Nexus 6 (Android 5.0.1)
(Assignee)

Comment 1

3 years ago
That quoted code is called from 

        T.playerType = 'html5',
        T.hasFormatSupport = o.test('audio')

Right now, in Firefox on desktop canPlayType("audio/mpeg") returns maybe. canPlayType("audio/mp4; codecs='mp4a.40.2'") returns probably. Same on the Flame, but playback fails (on desktop and device).
(Assignee)

Comment 2

3 years ago
The page uses web sockets. I'm not quite sure why it uses web sockets, but I note that we never seem to run the onopen callback, and that setting a breakpoint in the onopen callback makes BlinkOpera hang in a similar state to what Firefox does:

e.onopen = function() {
   clearTimeout(t), t = null, o.start(), s.isConnected = s.hasConnected = !0, u()
}

Some connection problem with the web socket?
(Assignee)

Comment 3

3 years ago
I note that some of their pages have mixed content problems:

Mixed Content: The page at 'https://m.mixcloud.com/magnatune/2015-01-17-bach-podcast-from-magnatune/' was loaded over HTTPS, but requested an insecure video 'http://throttle.magnatune.com/podcasts/mp3/magnatune_bach_podcast_2015_01_17.mp3'. This content should also be served over HTTPS.
2(index):1 Mixed Content: The page at 'https://m.mixcloud.com/magnatune/2015-01-17-bach-podcast-from-magnatune/' was loaded over HTTPS, but requested an insecure video 'http://throttle.magnatune.com/podcasts/mp3/magnatune_bach_podcast_2015_01_17.mp3'. This content should also be served over HTTPS.
(Assignee)

Comment 4

3 years ago
(It might be easier to debug this if we had bug 1103257 and bug 1103263 fixed in devtools to be able to review WebSocket traffic)
(Assignee)

Updated

3 years ago
Assignee: nobody → hsteen
Status: NEW → ASSIGNED
(Assignee)

Comment 5

2 years ago
Fails because MP3 playback is unsupported.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787227
(Assignee)

Comment 6

2 years ago
Hm, that's not it. Fennec plays other mp3-files OK.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

2 years ago
Works fine for me now in Nightly on Android (although all links here are now dead, so go to "Discover" and pick something that's fresh)
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.