librecovery needs liblog in Lollipop

RESOLVED FIXED in 2.2 S4 (23jan)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: diego, Assigned: viralwang)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
librecovery_test fails to build otherwise with the error below:

librecovery_test (out/target/product/msm8909/obj/EXECUTABLES/librecovery_test_intermediates/LINKED/librecovery_test)
librecovery/librecovery.c:68: error: undefined reference to '__android_log_print'
librecovery/librecovery.c:111: error: undefined reference to '__android_log_print'
librecovery/librecovery.c:123: error: undefined reference to '__android_log_print'
librecovery/librecovery.c:137: error: undefined reference to '__android_log_print'
collect2: error: ld returned 1 exit status
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
(Reporter)

Updated

4 years ago
Blocks: gonk-L
(Assignee)

Comment 1

4 years ago
Hi Michael,

Looks like this build error exist since JB
Could you please help to review this patch?
Thank you!

Hi Diego,

Could you please also check this patch in your side?
It works in Nexus-5 with Lollipop.
Thank you!
Attachment #8550221 - Flags: review?(mwu)
Attachment #8550221 - Flags: feedback?(dwilson)
(Reporter)

Updated

4 years ago
Attachment #8550221 - Flags: feedback?(dwilson) → feedback+

Comment 2

4 years ago
Is it possible to use the shared library version of this?

Comment 3

4 years ago
Oh nevermind, it's for a test, so that doesn't matter at all.

Updated

4 years ago
Attachment #8550221 - Flags: review?(mwu) → review+
(Assignee)

Comment 4

4 years ago
add reviewer in comment
Assignee: nobody → vwang
Keywords: checkin-needed
https://github.com/mozilla-b2g/librecovery/commit/1b3591a50ed352fc6ddb77462b7b35d0bfa555a3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S4 (23jan)
Viral, can we uplift this to 2.2 if ready ? :mvines shared that its already in CAF trees : https://www.codeaurora.org/cgit/quic/lf/b2g/build/tree/patch/LF.BR.1.2.3/librecovery/Bug-1122162-librecovery_test-needs-liblog.patch and is really low risk.
Flags: needinfo?(vwang)
(Assignee)

Comment 7

4 years ago
(In reply to bhavana bajaj [:bajaj] from comment #6)
> Viral, can we uplift this to 2.2 if ready ? :mvines shared that its already
> in CAF trees :
> https://www.codeaurora.org/cgit/quic/lf/b2g/build/tree/patch/LF.BR.1.2.3/
> librecovery/Bug-1122162-librecovery_test-needs-liblog.patch and is really
> low risk.

Yes, I think it's ready to uplift to 2.2!
Flags: needinfo?(vwang)
Comment on attachment 8550221 [details] [review]
add liblog in Android.mk to fix the build error

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8550221 - Flags: approval-gaia-v2.2?(bbajaj)
blocking-b2g: 2.2? → 2.2+
Attachment #8550221 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.