Upgrade from 34.x to 35.0 resets the default search provider to Yahoo

RESOLVED DUPLICATE of bug 1121252

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1121252
3 years ago
3 years ago

People

(Reporter: K. Katsnelson, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

- Previously upgraded to the version 34, that changed the default search provider to Yahoo (that was documented).
- Changed the default search provider back to Google.
- Today accepted an automatic software upgrade notification and upgraded to version 35.0. 


Actual results:

Upon restart, the default search provider changed to Yahoo.


Expected results:

Firefox keeps the user's default search engine preference.
Component: Untriaged → Search

Comment 1

3 years ago
Please see bug 1121252 comment 5:

(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from bug 1121252 comment #5)
> Sean: it would be useful if you could confirm that you were running 34.0,
> and not 34.0.5, before you upgraded to Firefox 35.
> 
> Assuming so, then it's possible you encountered an edge case in our testing
> of the default switch.
> 
> Firefox 34 was only offered to a small percentage of our users between Dec
> 1st and Dec 8th (by throttling the update rate). To have received this
> update, you would have needed to either be in the lucky ~2% who happened to
> get the update offer, or you would have needed to manually check for updates
> (using the about dialog), which isn't affected by throttling. Given how on
> top of our updates you are, I'm guessing you probably manually checked for
> updates in this time period :)
> 
> Firefox 34.0 did not have a change in the default search engine
> (Google->Yahoo), only 34.0.5 did. However, using the 34.0 "whatsnew" page,
> which opens after an update, we experimented with a few different ways to
> introduce the upcoming new default, and made it possible for users to get a
> "sneak peak" of the new default (Yahoo), by switching their active search
> engine automatically (or after a prompt). If you encountered one of these,
> then you would have seen a switch to Yahoo in the search bar, but this would
> have been recorded as a "switch to a non-default engine". If you then went
> and switched back to Google yourself, that was therefore recorded as "switch
> to the default engine". Given that, during subsequent upgrade to 35 (which
> contained the same default change as 34.0.5), would have seen that you were
> using the old default (Google), and thus switched you to the new default
> (Yahoo).
> 
> The takeaway is this: it was possible, under these specific set of
> conditions, for you to get an "automated" switch to Yahoo twice - once on
> update to 34.0, and then again on update to 35.0, *if* you switched from
> Yahoo->Google after the first "automated switch", while still running 34.0.
> This can only have happened once (it won't be possible for it to happen
> again), and only if you were one of the "lucky few" to get 34.0 instead of
> going directly from 33.X->34.0.5 (most of our users).
> 
> I'm going to close this out since this was a one-time fluke, not something
> we can go back in time and fix, but hopefully that explanation helps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121252
You need to log in before you can comment on or make changes to this bug.