Closed Bug 11228 Opened 21 years ago Closed 21 years ago

usemap can't deal with map names containing whitespace

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

Sun
Solaris
defect

Tracking

()

VERIFIED DUPLICATE of bug 11453

People

(Reporter: tor, Assigned: joki)

References

()

Details

Not sure this is the right component (might even be a parsing problem),
but "Event Handling" seemed like a good starting point.

This testcase of using a map name containing a space works in Netscape 4.61,
but fails with apprunner (8/3 CVS pull).  apprunner doesn't do anything when
the image is clicked on.

<img src="http://www.mozilla.org/status/tree.gif" usemap="#foo bar" width="49"
height="60">
<map name="foo bar">
  <area shape="rect" coords="0,0,48,59" href="http://www.mozilla.org/">
</map>

Removing the whitespace ("foo bar" -> "foobar") causes it work in both
Netscape and apprunner.

<img src="http://www.mozilla.org/status/tree.gif" usemap="#foobar" width="49"
height="60">
<map name="foobar">
  <area shape="rect" coords="0,0,48,59" href="http://www.mozilla.org/">
</map>
QA Contact: janc → elig
[QA Assigning to self --- imagemap issue.]
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 11453 ***
Status: RESOLVED → VERIFIED
Verifying as duplicate. (Technically, the other bug is a duplicate, but it has
more information, so we'll make engineering's life easier by leaving that one
open. ;)
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.