Closed Bug 1122800 Opened 6 years ago Closed 6 years ago

RuntimeWarning: couldn't determine platform's TOTAL_PHYMEM

Categories

(Firefox Build System :: Mach Core, enhancement)

36 Branch
x86_64
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 930808

People

(Reporter: rillian, Unassigned)

Details

Typing './mach build' on my dev code on top of the 'beta' branch from the gecko-dev repo, I get:

$ ./mach build
/home/giles/mozilla/firefox/python/psutil/psutil/_pslinux.py:108: RuntimeWarning: couldn't determine platform's TOTAL_PHYMEM
  warnings.warn("couldn't determine platform's TOTAL_PHYMEM", RuntimeWarning)
Error running mach:

    ['build']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AttributeError: 'module' object has no attribute 'get_sysinfo'

  File "/home/giles/mozilla/firefox/python/mozbuild/mozbuild/mach_commands.py", line 290, in build
    monitor.init(warnings_path)
  File "/home/giles/mozilla/firefox/python/mozbuild/mozbuild/controller/building.py", line 164, in init
    self.resources = SystemResourceMonitor(poll_interval=1.0)
  File "/home/giles/mozilla/firefox/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py", line 188, in __init__
    virt = psutil.virtual_memory()
  File "/home/giles/mozilla/firefox/python/psutil/psutil/__init__.py", line 1170, in virtual_memory
    return _psplatform.virtual_memory()
  File "/home/giles/mozilla/firefox/python/psutil/psutil/_pslinux.py", line 143, in virtual_memory
    total, free, buffers, shared, _, _ = _psutil_linux.get_sysinfo()


Machine is Fedora 21 Linux x86_64.
Last upstream commit is the uplift of bug 1106935 to 36 beta.
This is a duplicate of bug 930808 and bug 1116194. We should consider uplifting those so people don't run into this building old trees.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 930808
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.