Closed Bug 1122850 Opened 5 years ago Closed 5 years ago

Use setPowerMode interface for HWC 1.4 and above

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S6 (20feb)
blocking-b2g 2.2+
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: ikumar, Assigned: sushilchauhan)

References

Details

(Whiteboard: [caf priority: p2][CR 793775])

Attachments

(1 file, 1 obsolete file)

For HWC version 1.4 and above, HAL does not support blank interface.
Hence, setPowerMode() should be used in place of blank().
Assignee: nobody → sushilchauhan
blocking-b2g: --- → 2.2?
For HWC version 1.4 and above, HAL does not support blank interface. Hence, setPowerMode() should be used in place of blank().
Attachment #8559972 - Flags: review?(dwilson)
Comment on attachment 8559972 [details] [diff] [review]
Use setPowerMode interface for HWC 1.4 and above.

LGTM
Attachment #8559972 - Flags: review?(dwilson) → review+
Uploading the HG version of the reviewed patch.
Attachment #8559972 - Attachment is obsolete: true
Attachment #8560030 - Flags: review+
Try server link: https://tbpl.mozilla.org/?tree=Try&rev=a466025f55a0
Keywords: checkin-needed
NI to get "blocking-b2g: 2.2?" approval.
Flags: needinfo?(bbajaj)
Comment on attachment 8560030 [details] [diff] [review]
Use setPowerMode interface for HWC 1.4 and above. r=dwilson

Review of attachment 8560030 [details] [diff] [review]:
-----------------------------------------------------------------

[Approval Request Comment]
Bug caused by (feature/regressing bug #): As per Android Lollipop HWC header, HAL does not support blank interface for HWC version 1.4 and above.
User impact if declined: Issues in black/un-blank use-case (suspend/resume), if it is HWC 1.4 HAL.
Testing completed: Basic display testing.
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch: No
Attachment #8560030 - Flags: approval-mozilla-b2g37?
Whiteboard: [CR 793775]
Whiteboard: [CR 793775] → [caf priority: p2][CR 793775]
https://hg.mozilla.org/mozilla-central/rev/3d85bc28eaad
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
Flags: needinfo?(bbajaj)
Attachment #8560030 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
blocking-b2g: 2.2? → 2.2+
No longer blocks: CAF-v3.0-FL-metabug
You need to log in before you can comment on or make changes to this bug.