form controls fail to emit TYPE_VIEW_CLICKED events upon state change.

RESOLVED FIXED in Firefox 38

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: drew, Assigned: maxli)

Tracking

unspecified
mozilla38
All
Android
Points:
---

Firefox Tracking Flags

(firefox38 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Confirmed on Kitkat, with firefox nightlies. Example page:
http://www.tizag.com/htmlT/htmlcheckboxes.php
A more in-depth discussion on the issue, with a screenreader patch:
https://groups.google.com/forum/#!topic/spielproject/aCcnm_Y48Ow

Comment 1

4 years ago
Steps to reproduce:
Open a website where there are some checkboxes or radio buttons in nightly.
Use your favorite method of navigation to reach a checkbox and observe its state checked or unchecked.
Now double tap anywhere on the screen in order to change the state of that checkbox.

Results:
checkbox will toggle the state but you will receive no feetback from your screen reader.

Expected results:
Your screen reader will announce new state as you double tap on a radio button and / or a checkbox.

Comment 2

4 years ago
Eitan, Max, are there any historic reasons we emit the event when clicking a button, but not when togling a checkbox?

Updated

4 years ago
Flags: needinfo?(maxli)
Flags: needinfo?(eitan)
(Assignee)

Comment 3

4 years ago
It appears we explicitly don't send it out and instead use a state change event.

https://mxr.mozilla.org/mozilla-central/source/accessible/jsat/Presentation.jsm#318
Flags: needinfo?(maxli)
This should get fixed. We have a special case for toggle controls as Max points out. Apparently it is broken.
Flags: needinfo?(eitan)
(Assignee)

Comment 5

4 years ago
Created attachment 8565624 [details] [diff] [review]
Patch

It seems like the check to prevent sending this was mistakenly added, since the state change event which we depend on explicitly calls the actionInvoked presenter.
Assignee: nobody → maxli
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8565624 - Flags: review?(eitan)
Comment on attachment 8565624 [details] [diff] [review]
Patch

Review of attachment 8565624 [details] [diff] [review]:
-----------------------------------------------------------------

This looks right. Thanks!
Attachment #8565624 - Flags: review?(eitan) → review+
Actually, one nit: could you write a comment on why the text is empty when the object is checkable?
https://hg.mozilla.org/mozilla-central/rev/41b3823ec717
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.