Downloads are disabled in non-owner accounts (like they were guest accounts.)

RESOLVED DUPLICATE of bug 1113658

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1113658
3 years ago
2 years ago

People

(Reporter: Rasmus Svesson, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.3.0
Build ID: 20141203072641

Steps to reproduce:

1. Switch to a non-owner account on an Android tablet (mine is a Nexus 9). Important: this is not a guest account!

2. Install latest Firefox Beta (after installation it claims to be "39.0beta" for me).

3. Browse the web and find a PDF. Try to download it.


Actual results:

Download is not started and a message like this is shown:

    "Downloads are disabled in guest sessions."

I'm not sure about what the exact wording would be in English locals, but I hope you get the idea. The above text is my translation of the following Swedish text:

    "Nedladdningarna är inaktiverat i gästsessioner."


Expected results:

The download of the PDF should have started. The download starts fine if I perform the steps in the owner account. It seems like Firefox confuses non-owner accounts with guest accounts.

I noticed this problem a few days ago. I'm not sure when the behavior changed, but it used to work correclty on my device as late as January the first. I'm not sure when updated Firefox since then or what version I used then.
(Reporter)

Comment 1

3 years ago
Just found Bug 1046941. It seems like the "this.isGuest" value erroneously is set to true for non-owner non-guest accounts.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113658
You need to log in before you can comment on or make changes to this bug.