the alert box called when, document.onkeyup JS event is triggered, goes in a loop

NEW
Unassigned

Status

()

Core
Event Handling
16 years ago
3 years ago

People

(Reporter: Madhur Bhatia, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
see attached testcase

1. hit a key to trigger the document.onkeyup JS event
2. an alert box will be displayed
3. hit the keyboard 'enter' --- 
The event goes into a loop
4. if i click the mouse button on the alert box 'ok' butoon, the event comes out 
of the loop.

Note: the event goes into the loop only if the keyboard is used to discard the 
alert box.

happens on all platforms
NS6.2 : 2001-10-22-0.9.4 branch build
NS6.2.1 : 2001-11-26-6.2.1 rtm build
(Reporter)

Comment 1

16 years ago
Created attachment 59447 [details]
testcase
(Reporter)

Updated

16 years ago
Keywords: testcase
OS: Windows 2000 → All
Hardware: PC → All
Summary: the alert box called when, document.onkeyup JS event is triggered, goes in a loop → the alert box called when, document.onkeyup JS event is triggered, goes in a loop

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 92014 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
I do not see how this bug is a duplicate of bug 92014.

92014 says that "If keydown event opens an alert box, and space is pressed the 
box is dismissed."

whereas, this bug specifies that "onkeyup event when triggered for the document 
object goes into a loop". Also checked this on 2001-11-26-10trunk build for 
win2000.

Reopening this bug. 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

15 years ago
It is slightly different from 92014 but only because 92014 only talks about the
space bar.  This is exactly the same bug but with the enter key instead. I'll
leave it as depends on rather than dupe 
Depends on: 92014
Target Milestone: --- → mozilla1.1

Updated

15 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 5

14 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=179125#c3

joki is no longer here
Assignee: joki → saari
Status: REOPENED → NEW
QA Contact: trix → ian

Comment 6

14 years ago
retargeting
Target Milestone: mozilla1.1alpha → Future

Comment 7

12 years ago
Got bit by this bug today, too. Rather annoying because I'm catching the
onkeyup-Event on a text input box, check for keyCode 13 and validate the
content. If it doesn't match the criterias, I display an alert() box, however
when they press the enter key, it's immidiately fired by the text input box again.
*** Bug 293565 has been marked as a duplicate of this bug. ***
Assignee: saari → nobody
QA Contact: ian → events

Updated

8 years ago
Duplicate of this bug: 357156

Updated

7 years ago
Duplicate of this bug: 566177

Updated

6 years ago
Duplicate of this bug: 624243

Comment 12

6 years ago
Created attachment 502412 [details]
testcase from Bug 624243

Comment 13

4 years ago
This still is a problem http://stackoverflow.com/questions/14636111/why-does-this-event-keep-getting-fired/14636497#comment20454352_14636497
Any update about this bug?
You need to log in before you can comment on or make changes to this bug.