All users were logged out of Bugzilla on October 13th, 2018

Mozilla mis-interpret to handle Chinese BIG5 URL

RESOLVED DUPLICATE of bug 138780

Status

()

RESOLVED DUPLICATE of bug 138780
17 years ago
17 years ago

People

(Reporter: kuno, Assigned: darin.moz)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.13-1smp i686; en-US; m18)
Gecko/20010110 Netscape6/6.5
BuildID:    2001112009

The above URL will automatically forwarded to a chinese URL:
http://michat.hongkong.com:8032/chat.html?inu=
(Reporter)

Comment 1

17 years ago
The mozilla nightly build on linux does not handle the chinese characters 
correctly. Trying again:

When opening the above URL, it will automaticatlly redirect to:
 
http://michat.hongkong.com:8032/chat.html?inu=路
人:jelly&isr=32&uid=XgHLLVVZaaeeEEJJnXX&es=EB1VUoKT

But mozilla (both win32 and linux) unable to send the correct chinese URL to 
hongkong.com, since it is not a valid url, hongkong.com sends back 
window.close to disconnect us.

When using opera / ie, a chat window should be opened.

Reproducible: always, tried on 10 different mozilla builds  0.9.6 and nightlies

steps to reproduce: open the above url and mozilla will be closed.

expected result: open a chat window , same as opera and windows ie
Summary: Mozilla mis-interpret to handle Chinese BIG5 URL → Mozilla mis-interpret to handle Chinese BIG5 URL
networking
Assignee: pchen → neeti
Component: XP Apps → Networking
QA Contact: sairuh → benc
Reporter: Is this still a problem with a NIGHTLY build ?
Component: Networking → Networking: HTTP

Comment 4

17 years ago
I can confirm that this bug exists (as elaborated upon in additional comment #1)
in Win98/Mozilla Build ID 2002042403.  Sometimes, though, instead of the window
closing, we just get the following -- and only the following -- in the source:

<center><p>&nbsp;</p><p>this name exist!

I guess it's basically the same thing (i.e., the server's response is equivalent
to "you've sent a garbage URL" or something like that).
I also verified that Netscape Communicator v4.79 and IE 6 handle this URL
correctly.  I can't leave as confirmed, though, so maybe someone else can.

Comment 5

17 years ago
Matti: please change "assigned to" and "qa" fields when changing components!
Assignee: neeti → darin
QA Contact: benc → tever
(Assignee)

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 138780 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.