694165-1.xhtml, 691096-1.html, 724978.xhtml, 730559.html | application timed out after 330 seconds with no output on OS X 10.10 debug

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: philor, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Various possibilities exist:

* the 10.10 slaves are lame

* we are lame on 10.10 debug (the suite times, tending toward 1.5 times the 10.8 debug suite times, make this seem like a good possibility)

* this test is too hard for 10.10 to handle

* this test is right in the spot in the crashtest suite when 10.10 debug says "I can't do any more, next hard test I'm quitting"

* it's a real failure, there actually is something about this test which needs to be fixed in 10.10-specific code

FWIW, I can't repro locally by just running the image/crashtests/ set, but I can by running the full suite (after disabling the bug 1121835 ones, which crash me first) - no sign of OOM, but it keeps the CPU sizzling away at 20-30% for the whole time.
(Reporter)

Comment 1

4 years ago
Skipped on 10.10 debug for now in https://hg.mozilla.org/integration/mozilla-inbound/rev/0d0cdc390be2 so we can see whether there are any more surprises hiding further down in the suite.
Keywords: leave-open
(Reporter)

Comment 3

4 years ago
Fun, with it skipped we hang during some random test in the 700Ks of layout/generic. Absolutely no idea what to do about that.
(Reporter)

Comment 4

4 years ago
Not so random, actually, and I do have one idea for what to do about it: blame the slow of bug 1125998 and skip even more in the meantime.

https://hg.mozilla.org/integration/mozilla-inbound/rev/e5ef14d05d10
Component: SVG → General
Depends on: 1125998
Product: Core → Testing
Summary: 694165-1.xhtml | application timed out after 330 seconds with no output on OS X 10.10 debug → 694165-1.xhtml, 691096-1.html, 724978.xhtml, 730559.html | application timed out after 330 seconds with no output on OS X 10.10 debug

Updated

4 years ago
Duplicate of this bug: 1128955

Updated

4 years ago
Duplicate of this bug: 1129045
(Reporter)

Updated

4 years ago
No longer blocks: 1121199
None of the tests in this bug are skipped on OSX anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: in-testsuite+
Keywords: leave-open
Resolution: --- → WORKSFORME
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
status-b2g-v2.5: fixed → ---
You need to log in before you can comment on or make changes to this bug.