[Flame][Built-in&System Keyboard] Keyboard pops up automatically when stopping an alarm in Alarm editing view.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: liuyong, Assigned: mcav)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Posted file logcat_1356.txt
[1.Description]:[Flame][v2.2][Built-in&System Keyboard] In Alarm editing view, invoke the keyboard,then wait for the alarm to ring, and then stop the alarm, keyboard is still displayed on Clock view.
Found time:13:56
Attachments:logcat_1356.txt, 1356.mp4

[2.Testing Steps]: 
1. Launch Clock and set an alarm on next one minute.
2. Tap "+" button in Clock view, then tap "Alarm name" field.
**The keyboard will be invoked.
3. Wait for alarm to ring, then tap "Stop" button, check the view.


[3.Expected Result]: 
3. The keyboard shouldn't  pop up automaitically.

[4.Actual Result]: 
3. It will return to Clock view, but the keyboard  pops up automaitically.

[5.Reproduction build]: 
Flame 2.2:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150118.035516
FW-Date         Sun Jan 18 03:55:27 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted video 1356.MP4
Can it be reproduced on the other branches (v2.1 & v2.0)?
Thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(liuyong)
Resolution: --- → INVALID
(Reporter)

Comment 3

4 years ago
Hi William,
   This issue can't be repro on Flame2.0 & 2.1.
Reproducing rate: 0/5

Flame 2.1 build:

Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452a023ae7b2
Build-ID        20150119001222
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.035259
FW-Date         Mon Jan 19 03:53:10 EST 2015
Bootloader      L1TC000118D0

Flame 2.0 build:

Gaia-Rev        736933b25ded904f0cb935a0d48f1f3cf91d33ad
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/6c9aefc84244
Build-ID        20150119000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.033618
FW-Date         Mon Jan 19 03:36:29 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(liuyong) → needinfo?(whsu)
(In reply to Coler from comment #3)
> Hi William,
>    This issue can't be repro on Flame2.0 & 2.1.
> Reproducing rate: 0/5

Thanks Coler!
Flags: needinfo?(whsu)
(Reporter)

Comment 5

4 years ago
Hi William,
   I think this is a issue,and I can repro this issue on latest Flame 2.2.Can you please check it again and change the state of this issue? Thanks.

Flame 2.2 build:

Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/be206fa2fb60
Build-ID        20150202002507
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150202.035604
FW-Date         Mon Feb  2 03:56:15 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(whsu)
(In reply to William Hsu [:whsu] from comment #2)
> Can it be reproduced on the other branches (v2.1 & v2.0)?
> Thanks.

Oops!... accident.
Set status to "REOPEN" and add "regression" tag here.
Status: RESOLVED → REOPENED
Flags: needinfo?(whsu)
Keywords: regression
Resolution: INVALID → ---
FWD to QA Gerry
Flags: needinfo?(gchang)
NI EPM to determine if this is a blocker.
Flags: needinfo?(gchang) → needinfo?(hochang)

Comment 9

4 years ago
blocking as regression. Hi Tim, I'll put you as assignee first and please reassign if needed, thanks.
Assignee: nobody → timdream
blocking-b2g: --- → 2.2+
Flags: needinfo?(hochang) → needinfo?(timdream)
QA Contact: bzumwalt
B2G-Inbound Regression Window:

Last working B2G-Inbound build:
Device: Flame 2.2
BuildID: 20141106050421
Gaia: 5b185fb3c26a814787b544cc9ef2770a8b223ec6
Gecko: 0b4fff979f4d
Version: 36.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken B2G-Inbound build:
Device: Flame 2.2
Build ID: 20141106053322
Gaia: 8ca903fe7b463a6974186e19d5ba667a1d59f02d
Gecko: d6e8daf74fde
Version: 36.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Working Gaia with Broken Gecko issue does NOT reproduce:
Gaia: 5b185fb3c26a814787b544cc9ef2770a8b223ec6
Gecko: d6e8daf74fde

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: 8ca903fe7b463a6974186e19d5ba667a1d59f02d
Gecko: 0b4fff979f4d


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/5b185fb3c26a814787b544cc9ef2770a8b223ec6...8ca903fe7b463a6974186e19d5ba667a1d59f02d


Issue appears to occur due to changes made in bug 1079748
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Issue also occurs on Flame 3.0

Previously focused keyboard pops up automatically after pressing stop on alarm attention screen.

Device: Flame 3.0
Build ID: 20150330010204
Gaia: be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gecko: dfe60814eda7
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Alive, can you take a look at this please? Looks like this might have been caused by the work done for bug 1079748.
Blocks: 1079748
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Not my regression. Alive, could you take a look at this? Thanks!
Assignee: timdream → nobody
Status: REOPENED → NEW
Flags: needinfo?(timdream)
Taken
Assignee: nobody → alive
Flags: needinfo?(alive)
Sorry, I don't think this is a system bug. We do re-focus the app after the attention is closed correctly - it's apps' choice to focus a 'invisible' input so we see the keyboard pop up.
Assignee: alive → nobody
Component: Gaia::Keyboard → Gaia::Clock
(Assignee)

Updated

4 years ago
Assignee: nobody → m
Target Milestone: --- → 2.2 S9 (3apr)
(Assignee)

Comment 17

4 years ago
Comment on attachment 8586483 [details] [review]
[gaia] mcav:clock-keyboard-focus > mozilla-b2g:master

Thanks to Alive's hint about window focus, the fix was easy to find.

Because we transition away from the Alarm Edit view after an alarm fires, the previously-focused "Alarm Name" field slides off the screen. The keyboard popping up was expected, since the Alarm Name field is still around.

To avoid this, we now blur any focused element before showing the alarm screen. This removes the focus, so that when the alarm fires, the keyboard doesn't need to come back up.

Tested and verified manually on master and v2.2. (An automated test for this edge case would be substantially more risky given the late nature of v2.2 and our current testing situation.)
Attachment #8586483 - Flags: review?(mmedeiros)
Comment on attachment 8586483 [details] [review]
[gaia] mcav:clock-keyboard-focus > mozilla-b2g:master

nice and clean solution, +1 for the comment explaining why we need to `blur()`
Attachment #8586483 - Flags: review?(mmedeiros) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

4 years ago
Comment on attachment 8586483 [details] [review]
[gaia] mcav:clock-keyboard-focus > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
  system changes

[User impact] if declined:
  the keyboard will pop up unexpectedly in very rare cases

[Testing completed]:
  manual verification, on Flame v2.2 and Flame master

[Risk to taking this patch] (and alternatives if risky):
  super low risk; one-line change with straightforward semantics.

[String changes made]: n/a
Attachment #8586483 - Flags: approval-gaia-v2.2?
Attachment #8586483 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 21

4 years ago
Posted video Verify_3.0.MP4
This issue has been verified successfully on Flame 3.0.The STR is same as Comment 0.

Reproduce rate:0/5.
Attachment:Verify_3.0.mp4

Device: Flame3.0 build(Pass)
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago

Comment 23

4 years ago
This issue verified successfully on flame 2.2
Flame 2.2:
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate         0/5
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.