[Flame][Contacts]Device will enter Contacts page when you tap "+" to add receiver.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: liuke, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.2 affected)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8551163 [details]
logcat_1426.txt

[1.Description]:
[Flame][v2.2][Contacts]When you tap "+" to enter select contact page, and input some keywords to search contact, then back to message page, tap the "+" again, device will enter Contacts page.
Found time:14:26
See attachment:1426.mp4 and logcat_1426.txt

[2.Testing Steps]: 
Premise: You have some contacts in Contacts app.
1.Launch Messages.
2.Create a new message.
3.Tap "+" in receiver box to enter select contact page.
4.Tap Search box, input some keywords, slide down page.
5.Tap "Cancel" -> "X" to back edit message page.
6.Repeat step 3.

[3.Expected Result]: 
6.After you tap the "+", device should enter select contact page.

[4.Actual Result]: 
6.After you tap the "+", device will enter Contacts app page.

[5.Reproduction build]: 
Flame 2.2:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150118.035516
FW-Date         Sun Jan 18 03:55:27 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Seldom Recurrence,1/30

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8551164 [details]
1426.MP4

Comment 2

4 years ago
I saw some warming messages. It may relate to this bug.


01-19 14:26:43.668 W/Communications( 3270): Content JS WARN: L10nError: "#type_l10n_id#" not found in en-US in app://communications.gaiamobile.org/contacts/index.html?pick 

01-19 14:26:43.668 W/Communications( 3270):     at reportMissingEntity (app://communications.gaiamobile.org/contacts/gaia_build_defer_index.js:173:1837)

01-19 14:26:43.668 W/Communications( 3270): Content JS WARN: L10nError: "#type_l10n_id#" not found in en-US in app://communications.gaiamobile.org/contacts/index.html?pick 

01-19 14:26:43.668 W/Communications( 3270):     at reportMissingEntity (app://communications.gaiamobile.org/contacts/gaia_build_defer_index.js:173:1837)

01-19 14:26:43.668 W/Communications( 3270): Content JS WARN: L10nError: "#type_l10n_id#" not found in en-US in app://communications.gaiamobile.org/contacts/index.html?pick 

01-19 14:26:43.668 W/Communications( 3270):     at reportMissingEntity (app://communications.gaiamobile.org/contacts/gaia_build_defer_index.js:173:1837)

01-19 14:26:43.968 W/Communications( 3270): [JavaScript Warning: "Will-change memory consumption is too high. Surface area covers 771470 pixels, budget is the document surface area multiplied by 3 (172480 pixels). All occurences of will-change in the document are ignored when over budget." {file: "app://communications.gaiamobile.org/contacts/index.html?pick" line: 0}]

01-19 14:26:46.528 W/AudioFlinger(  205): Thread AudioOut_2 cannot connect to the power manager service

01-19 14:26:46.528 E/AudioFlinger(  205): no wake lock to update!

01-19 14:26:46.958 I/GeckoDump(  209): [system] [ActivityWindow][Contacts][ActivityWindow_35][727.366]  Handling mozbrowserasyncscroll event...
Will nominate to 2.2? since it's a bad user experience and want triage to discuss about this, but taking into account the frequency 1/30, doesn't look like a blocker to me.
blocking-b2g: --- → 2.2?
triage: non-blocking per the repro rate. please renom if there's STR which is easier to repro.
ni to johan for he had some automation testing showing more details
blocking-b2g: 2.2? → -
Flags: needinfo?(jlorenzo)
Created attachment 8553702 [details] [diff] [review]
marionette-test.diff

I wasn't able to reproduce this issue with Marionette Python after 50 iterations. One note though: The scrolling move is currently not doable with Marionette. I tried to use the flick() method here[1]. No scroll down is shown on the screen.

[1] http://marionette-client.readthedocs.org/en/latest/reference.html?highlight=html#marionette.Actions.flick
Flags: needinfo?(jlorenzo)
(Reporter)

Comment 6

4 years ago
The bug still exist in latest Flame 2.2 build.

Fail rate:1/150
Found time:16:05
See attachment:1605.mp4 and logcat_1605.txt

Flame 2.2:
Build ID               20150330162503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.201412
Firmware Date          Mon Mar 30 20:14:21 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(echang)
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
(Reporter)

Comment 7

4 years ago
Created attachment 8585973 [details]
logcat_1605.txt
(Reporter)

Comment 8

4 years ago
Created attachment 8585975 [details]
1605.mp4
I reproduced that first time I tried but STR is not that solid, not able to reproduce it after that. other observation is that it takes more time to show the keyboard completely, and more time needed for the title of contact list to change to "X Select contact", the whole process is sluggish.
Flags: needinfo?(echang)
Duplicate of this bug: 1155126

Comment 11

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.