Add ability for a user to close a tab and save its state, for later reloading

VERIFIED WONTFIX

Status

()

enhancement
VERIFIED WONTFIX
5 years ago
2 years ago

People

(Reporter: t8av, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I had many (~10) tabs opened on websites such as facebook image albums and Twitter.


Actual results:

Firefox became very slow, and then crashed.



Expected results:

Firefox should include a possible user action, per tab ,to right-click it and call a command "Close tab and save its state".

Technically it will save tab state to hard disk, and will release RAM, which will prevent crashes.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675539
(In reply to :Gijs Kruitbosch from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 675539 ***

Bug 675539 is about automatically unloading tab state. This is about doing it manually in response to a user's request. It's worth keeping them separate.
Summary: "Close tab and save its state" action is most needed to prevent Firefox crashes whenever overloaded. → Add ability for a user to close a tab and save its state, for later reloading
Severity: normal → enhancement
Status: RESOLVED → REOPENED
Component: Untriaged → Session Restore
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Resolution: DUPLICATE → ---
See Also: → 675539
Version: 35 Branch → unspecified
This seems perfect for an add-on and very unlikely to become core functionality. Closing a tab and retrieving its state is easy, implementing a good UI to expose restorable tabs is probably a tad harder.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → WONTFIX
Reporter

Comment 4

5 years ago
(In reply to Tim Taubert [:ttaubert] from comment #3)
> This seems perfect for an add-on and very unlikely to become core
> functionality. Closing a tab and retrieving its state is easy, implementing
> a good UI to expose restorable tabs is probably a tad harder.

You are probably right, but who, and when, will implement this add-on?

Comment 5

5 years ago
> but who, and when, will implement this add-on?

Whoever wants to. Like any other functionality in any other free software application.
[Discussing that is offtopic here, as not request-specific.]
Reporter

Comment 6

5 years ago
This issue if of high importance, due to the very-frequent crashed of Firefox.
(In reply to t8av from comment #6)
> This issue if of high importance, due to the very-frequent crashed of
> Firefox.

Don't generalize your experience. For me for exmaple Firefox crashes extremely seldomly.
I already told you in bug 675539 comment 137 to investigate what's causing your frequent crashes or to simply create a new profile/reset your current profile.

Sebastian

Updated

4 years ago
See Also: → 1128502
Reporter

Comment 8

4 years ago
My experience is the same experience of millions of users.

Closing this bug without a serious discussion is an outrage.
Reporter

Comment 9

4 years ago
The enhancement that I proposed is extremely important.

I do not accept that an individual will decide to close it ("wontfix"), without a serious discussion.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 10

4 years ago
(In reply to t8av from comment #9)
> The enhancement that I proposed is extremely important.
> 
> I do not accept that an individual will decide to close it ("wontfix"),
> without a serious discussion.

Your suggestion is really only usable by expert users, and including such a menu wouldn't really help anyone else. Plus, if we ever decided that writing stuff to disk was an acceptable way of dealing with multiple-tab-perf, we would probably want to do it automatically rather than relying on the user to make decisions about which tabs to hibernate.

This is exactly why this is good for an add-on, and not good for default Firefox. Your proposal is, in your eyes, really important *to you*. It isn't for at least 99% of all other Firefox users. If you feel that that assessment is wrong, the best course of action would be writing to firefox-dev to discuss this further. ( https://wiki.mozilla.org/Firefox/firefox-dev )
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Status: RESOLVED → VERIFIED
Reporter

Comment 11

4 years ago
I am 100% sure that the above assessment is very wrong. 

Whenever I have free time I will contact Firefox dev as you suggested.

Regarding add-on: who can implement it? Is there any forum for proposed add-ons?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 12

4 years ago
> who can implement it?

Whoever feels convinced that implementing this is actually a good idea. I'm not aware of some forum. Pretty often people scratch their own itch when writing code instead of writing stuff for others. :)

Comment 13

4 years ago
(In reply to t8av from comment #11)
> I am 100% sure that the above assessment is very wrong. 
> 
> Whenever I have free time I will contact Firefox dev as you suggested.
> 
> Regarding add-on: who can implement it? Is there any forum for proposed
> add-ons?

Andre is right, though you could try writing to mozilla.dev.extensions: https://groups.google.com/forum/?fromgroups#!forum/mozilla.dev.extensions
Flags: needinfo?(gijskruitbosch+bugs)
Reporter

Comment 14

4 years ago
On second thought - maybe no need to implement an add-on, because this feature is already implemented in Firefox, but not accessible to the user, in most cases (described below):

1. Let's assume that I opened 20 tabs, and also, let's assume that Firefox crashed.

2. When starting Firefox after crash, you get the "after crash menu", which allows you to access each one of the tabs. In other words, Firefox always saves the tabs to the hard disk.

Is it OK with you if I change the title of this bug to "make saved tabs accessible to the user", so we can reopen this bug?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 15

4 years ago
No, not okay.
Reporter

Comment 16

4 years ago
I can, of course, do it manually:

1. Open many tabs.
2. Terminate the Firefox process using C:\Windows\System32\Taskkill /F /im firefox.exe
3. Get the desired menu.

Comment 17

4 years ago
None of what you've said changes whether we want to implement the UI and extra code in Firefox itself, so, no. Please write to firefox-dev and make your case there.
Flags: needinfo?(gijskruitbosch+bugs)
Comment hidden (offtopic)
You need to log in before you can comment on or make changes to this bug.