Remove the dom.indexedDB.enabled pref

RESOLVED DUPLICATE of bug 1488583

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1488583
4 years ago
7 months ago

People

(Reporter: Ms2ger, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
dev-doc-needed so we check if we still have occurence of it in the MDN when it lands.
Keywords: dev-doc-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1079355
(Reporter)

Comment 3

4 years ago
Not the same thing.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
It is either a duplicate of 1079355 or WONTFIX. Please see the discussion we had in the other bug.

Comment 5

3 years ago
Until IndexedDB is handled in the same way as cookies with respect to accepting/clearing and third-party behavior, this pref should exist.
Priority: -- → P5
Duping to bug 1488583 which is the same idea (eliminate the pref) but with some additional explanation/context to eliminate confusion.

(In reply to oyenamit from comment #5)
> Until IndexedDB is handled in the same way as cookies with respect to
> accepting/clearing and third-party behavior, this pref should exist.

Happily, IndexedDB responds to the same storage decision-making process for accepting cookies and the clearing mechanisms have been updated to also clear IndexedDB.  (In the past, it was true that there were several ways to clear data and these could potentially fail to include the relevant IndexedDB data.)
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1488583
You need to log in before you can comment on or make changes to this bug.