crash in mozilla::gfx::GetCairoSurfaceForSourceSurface(mozilla::gfx::SourceSurface*, bool, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&)

RESOLVED DUPLICATE of bug 1126490

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1126490
5 years ago
5 years ago

People

(Reporter: dmajor, Unassigned)

Tracking

({crash, topcrash})

unspecified
x86
Windows NT
Points:
---

Firefox Tracking Flags

(firefox36+ wontfix, firefox37+ wontfix, firefox38+ wontfix)

Details

(Whiteboard: [gfx-noted], crash signature)

This bug was filed from the Socorro interface and is 
report bp-a07a2fb6-4a31-4e08-8054-427e52150113.
=============================================================

GetCairoSurfaceForSourceSurface receives a null |aSurface| from various callers (I've seen different stacks in different reports). Bas can you take this?
Flags: needinfo?(bas)
[Tracking Requested - why for this release]: This is a top crash on nightly and aurora, and to a lesser extent beta.
I will look at this.
Whiteboard: [gfx-noted]
I just hit this while running some you tube tests on nightly. Will see if I can reproduce it.

https://crash-stats.mozilla.com/report/index/e41a7c85-bfa3-4c7f-891f-c05e62150130
got one today :

https://crash-stats.mozilla.com/report/index/b117f95e-1b07-459e-a016-bb2f72150131  this happened when the windows reported memory usage as 96%.

similar bug i filed : bug 1128170

Can repro it pretty consistently. Youtube video link 
https://www.youtube.com/watch?v=pfHxl46KyZM&index=4&list=RD79r4GpIXysQ  watch in 720p in HTML5 mode. 
Before the crash, the video started flickering like crazy.
Bas, any news on this? Beta 6 gtb today.
Nothing this is the #4 topcrash on Nightly with 926/18111 crashes in the last 7 days.
Keywords: topcrash
Seth, it looks like this is an imagelib problem.
Component: Graphics → ImageLib
Flags: needinfo?(seth)
It also looks like this could be OOM. The two crashes linked from the bug have high memory usage. dmajor can we confirm that these are mostly caused in high memory usage situations.
Flags: needinfo?(dmajor)
I'm pretty sure either |mOptSurface->IsValid()| is returning false in imgFrame.cpp, or else we're getting bitten by a fallible allocation that we're not checking for somewhere. (Though I don't immediately see it; most of the obvious allocations look infallible.)

This looks pretty closely related to bug 1126490. I'm going to add a second patch in that bug for VectorImage. Separately, DrawableFrameRef needs to be redesigned to handle these situations. That would eliminate the need for bug 1126490 in a much cleaner way, but such a patch would not be upliftable.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(seth)
Resolution: --- → DUPLICATE
Duplicate of bug: 1126490
Flags: needinfo?(bas)
Flags: needinfo?(dmajor)
You need to log in before you can comment on or make changes to this bug.