Closed Bug 1123972 Opened 5 years ago Closed 3 years ago

Increase browser.search.geoip.timeout to 3 seconds

Categories

(Firefox :: Search, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 52
Tracking Status
firefox52 --- fixed

People

(Reporter: markh, Assigned: mkaply)

References

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

From bug 1116217 comment 3:

> Fetch time:
> 
> - 1.5 seconds median
> - 2.6 seconds 75th percentile
> - 6-13 seconds 95th percentile
> Based on those, I'd say increasing browser.search.geoip.timeout from 2
> seconds to 3 seconds might still be worth it.

and bug 1116217 comment 4:

> Our main concern with that timeout is that the search service is forced 
> to initialize synchronously during this timeout. 
> SEARCH_SERVICE_COUNTRY_FETCH_CAUSED_SYNC_INIT tracks this, and 
> currently 147 submissions from a total of ~10k (~2%) are hitting this,
> so I'd be inclined to agree

Hence this bug.
Looking at SEARCH_SERVICE_COUNTRY_FETCH_TIME_MS for release 36, we get a similar pattern:

- 1.74s median
- 2.79s 75th percentile
- 8-10s 95th percentile

SEARCH_SERVICE_COUNTRY_FETCH_CAUSED_SYNC_INIT is at 4% (~10k hits).
Priority: -- → P3
Whiteboard: [fxsearch]
Rank: 35
We're seeing this a lot trying to test things through proxies, and also when testing from Asia, so I would be inclined to agree.

In my tests running through a proxy in Taiwan, I was hitting getting results in 2 to 2.5 milliseconds.

Having this at three seconds would make our lives a ton easier.
Assignee: nobody → mozilla
That comment I removed is no longer true. The high value in telemetry is 100000.

https://dxr.mozilla.org/mozilla-central/source/toolkit/components/telemetry/Histograms.json#5971
Comment on attachment 8794381 [details]
Bug 1123972 - Up search geo timeout to 3 seconds.

https://reviewboard.mozilla.org/r/80868/#review79676
Attachment #8794381 - Flags: review?(florian) → review+
Duplicate of this bug: 1271474
https://hg.mozilla.org/mozilla-central/rev/aa5a378b17f1
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
I have reproduced this bug with Nightly 38.0a1 (2015-01-20) on Windows 7 , 64 Bit !

This bug's fix is verified with latest Nightly

Build ID    20161007030207
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
[bugday-20161005]
You need to log in before you can comment on or make changes to this bug.