Closed Bug 1124201 Opened 5 years ago Closed 5 years ago

Remove NonProxyLookupOwnProperty

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38

People

(Reporter: evilpie, Assigned: evilpie)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached patch non-proxy-lookupSplinter Review
Removes another lookup hook caller. Gets rid of some ugly code in GetOwnPropertyDescriptor as well.
Attachment #8552476 - Flags: review?(jorendorff)
Blocks: 1122293
Comment on attachment 8552476 [details] [diff] [review]
non-proxy-lookup

Review of attachment 8552476 [details] [diff] [review]:
-----------------------------------------------------------------

Wow. I really appreciate this one. It's quite a nice improvement.

::: js/src/builtin/Object.cpp
@@ +575,5 @@
>      CallArgs args = CallArgsFromVp(argc, vp);
>  
>      HandleValue idValue = args.get(0);
>  
>      /* Step 1, 2. */

While you're here, please adjust the comment to point out that this is a pure optimization (like the comment already in obj_propertyIsEnumerable).
Attachment #8552476 - Flags: review?(jorendorff) → review+
QA Contact: evilpies
https://hg.mozilla.org/mozilla-central/rev/eb8001361b46
Assignee: nobody → evilpies
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Duplicate of this bug: 770196
You need to log in before you can comment on or make changes to this bug.