Closed Bug 1124461 Opened 5 years ago Closed 5 years ago

Netmonitor not properly parsing JSON responses

Categories

(DevTools :: Netmonitor, defect)

37 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 982319

People

(Reporter: jsantell, Unassigned)

References

(Blocks 1 open bug)

Details

Look at the JSON XHR's on this page (after entering in your bugzilla email)
http://bugmotodo.org/

In the 'response' tab, it's all garbled like an encoding issue, with a JSON.parse error displaying.

Go to https://mozillians.org/en-US/u/jsantell/ and view network requests. Other than the images, 90% of the requests have the JSON parse error (even the HTML/CSS files are displayed as garbage).

Appears to be only in e10s (On Fx38)
Blocks: dte10s
They are encoded, and we don't decode in the e10s yet.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 982319
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.