crash in FrameManager::ReResolveStyleContext

VERIFIED DUPLICATE of bug 105619

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 105619
16 years ago
15 years ago

People

(Reporter: John Bandhauer, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
This crashes because the oldColor->mBackgroundImage it got from the oldContext
is not a valid string object.

This is perhap a dup of a similar bug where a style context has a bad string in
a font. But I can't find that bug right now anyway.

This is from a posting in the newsgroup:
news://news.mozilla.org:119/3C03C2D7.2060103@nc.rr.com

I'll attach a stacktrace.
(Reporter)

Comment 1

16 years ago
Created attachment 59549 [details]
Win32 stacktrace of crash
(Assignee)

Comment 2

16 years ago
I've been looking at this bug, and all I can say is that this really isn't
supposed to be able to happen.  I probably need to run this testcase under purify...

*** This bug has been marked as a duplicate of 105619 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Ah, the bug I was looking for had been marked a dup of *that* bug!

Comment 4

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.