If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[e10s] Unable to access OpenH264 license from add-on manager

RESOLVED DUPLICATE of bug 1047603

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1047603
3 years ago
3 years ago

People

(Reporter: spohl, Unassigned)

Tracking

(Blocks: 2 bugs)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s?)

Details

(Reporter)

Description

3 years ago
Steps:
1. Tools > Add-ons
2. For OpenH264, click on "More" or the Preferences button
3. Click on "License information".

Actual:
Spinning progress indicator, followed by blank page.

Expected:
License displays.

This does not occur when the add-on manager is launched in a non-e10s window.
This e10s bug will also affect EME CDM license links.
Blocks: 653064, 1015800
tracking-e10s: --- → ?
Hardware: x86 → All
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1114299
(Reporter)

Comment 3

3 years ago
Mike, are you convinced that this is the same issue as bug 1114299? I, for one, am not able to reproduce the problem with the test case in bug 1114299. After clicking the link, https://www.mozilla.org/en-US/ is loaded correctly and the browser chrome looks correct. However, clicking the link to the license file in the OpenH264 preference pane in the addon manager gives me a spinning wheel, followed by a blank page. The license file never loads. Could the difference be that we're trying to load a "chrome://" URL here?
Flags: needinfo?(mconley)
(Reporter)

Comment 4

3 years ago
I guess I should add that I tested this on OSX 10.10.2 with a local build based off of changeset 3bf7ed413e87 [1].

[1] https://hg.mozilla.org/mozilla-central/rev/3bf7ed413e87
(In reply to Stephen Pohl [:spohl] from comment #3)
> Mike, are you convinced that this is the same issue as bug 1114299? I, for
> one, am not able to reproduce the problem with the test case in bug 1114299.
> After clicking the link, https://www.mozilla.org/en-US/ is loaded correctly
> and the browser chrome looks correct. However, clicking the link to the
> license file in the OpenH264 preference pane in the addon manager gives me a
> spinning wheel, followed by a blank page. The license file never loads.
> Could the difference be that we're trying to load a "chrome://" URL here?

Gah, sorry - sloppily duped. I meant to dupe it to bug 1047603. Thanks for the heads up. :)
Flags: needinfo?(mconley)
Duplicate of bug: 1047603
You need to log in before you can comment on or make changes to this bug.