Closed Bug 1124549 Opened 5 years ago Closed 5 years ago

reftests/canvas/784573-1.html fails on OS X 10.10

Categories

(Core :: Canvas: 2D, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38

People

(Reporter: philor, Assigned: philor)

References

Details

Attachments

(1 file)

Attached file reftest.log
try: -b o -p macosx64 -u reftest[10.10] -t none

https://treeherder.mozilla.org/logviewer.html#?job_id=4381340&repo=try

16:30:23 INFO - REFTEST TEST-LOAD | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/layout/reftests/canvas/784573-1.html | 4223 / 11728 (36%)
16:30:23 INFO - REFTEST TEST-LOAD | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/layout/reftests/canvas/784573-1-ref.html | 4223 / 11728 (36%)
16:30:24 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/layout/reftests/canvas/784573-1.html | image comparison (==), max difference: 1, number of differing pixels: 128
...
16:30:24 INFO - REFTEST INFO | Loading a blank page
16:30:24 INFO - REFTEST TEST-END | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/layout/reftests/canvas/784573-1.html
Blocks: 784573
Oh, is this just the same thing that the existing AzureQuartz fuzz is for, only this brings it up to 128 instead of 113 pixels?
Flags: needinfo?(ajones)
Indeed, had I just looked at the annotation for this, and the annotation for the other things that were also tens of thousands of pixels off by one or two on AzureQuartz that were also just a few pixels short, I could have figured that out myself.

Adjusted in https://hg.mozilla.org/integration/mozilla-inbound/rev/a18024a0bd19
Assignee: nobody → philringnalda
Flags: needinfo?(ajones)
https://hg.mozilla.org/mozilla-central/rev/a18024a0bd19
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.