Closed Bug 1124663 Opened 7 years ago Closed 7 years ago

Menu flashes when clicked then is truncated (in non-private windows)

Categories

(Firefox :: Untriaged, defect)

36 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1029937

People

(Reporter: klint, Unassigned)

Details

(Keywords: regression, Whiteboard: [testday-20150123])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150120155007

Steps to reproduce:

I click on the menu icon


Actual results:

The menu is displayed briefly in its entirety.
Then it disappears.
When clicking again, the only pieces left in the menu are those ones:
http://vvcap.net/db/Zg-2JUwX5AggZn_VlLZi.htp

Note that doing it in a Private Mode windows does not show the issue.


Expected results:

The menu should have stayed on the screen.
hi, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, probably an addon is interfering here...

[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]
Flags: needinfo?(klint)
Yes, you were right actually. The issue does not occur in safe mode.

The problem is that I have 95 enables addons, and there is still no add on that would retain a global addons initial configuration, then deactivate half of them, and again, and again, to narrow down the problem by dichotomy ;) I wish such an addon existed....
Flags: needinfo?(klint)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

I cannot reproduce.
Whiteboard: [testday-20150123]
After further tests, I can confirm that it is due to the Switchy addon. And not related to FF36 itself.
I have reported the issue to the addon page and compatibility reporter.
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Regression window:
Good, Panel UI is opened properly:
https://hg.mozilla.org/integration/fx-team/rev/758d1cb4568b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141105162147

Bad, Panel UI is broken:
https://hg.mozilla.org/integration/fx-team/rev/201edc7cadb5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141105165448

Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=758d1cb4568b&tochange=201edc7cadb5

Suspect:  Bug 1083327
Blocks: 1083327
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Steps to reproduce:
1. Start Firefox with newly created profile
2. Install https://addons.mozilla.org/en-US/firefox/addon/switchy/?src=search
3. Right click switchy toolbutton and choose "Move to Menu"
4. Click Hamburger button

Actual Results:
Fails to open Panel UI
Flags: needinfo?(dtownsend)
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(dtownsend)
Resolution: --- → DUPLICATE
Duplicate of bug: 1029937
You need to log in before you can comment on or make changes to this bug.