[Messages] We should not add the hidden (+0) text at the end of the header

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: julienw, Assigned: azasypkin)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [sms-papercuts][sms-sprint-2.2S5])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Currently when we display the header for a 1-contact thread, we're adding a (+0) text for code consistency with the several-contacts case.

However, because gaia-header uses textContent to do the header font size calculation, the font-size is finally smaller than what it could be.

As a result we should not add this hidden (+0) in this case.
(Assignee)

Comment 1

4 years ago
Created attachment 8555341 [details] [review]
GitHub pull request URL
(Assignee)

Comment 2

4 years ago
Comment on attachment 8555341 [details] [review]
GitHub pull request URL

Hey Julien,

Could you please review the patch?

Thanks!
Attachment #8555341 - Flags: review?(felash)
(Assignee)

Updated

4 years ago
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: [sms-papercuts] → [sms-papercuts][sms-sprint-2.2S5]
(Reporter)

Comment 3

4 years ago
Comment on attachment 8555341 [details] [review]
GitHub pull request URL

2 small comments, and I see we both agree for both :)

please request review once you're ready !
Attachment #8555341 - Flags: review?(felash)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8555341 [details] [review]
GitHub pull request URL

Thanks for review! Suggestions addressed in the separate commit.
Attachment #8555341 - Flags: review?(felash)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8555341 [details] [review]
GitHub pull request URL

r=me with a nit
thanks !
Attachment #8555341 - Flags: review?(felash) → review+
(Reporter)

Comment 6

4 years ago
Please request an approval for v2.2 too :)
(Assignee)

Comment 7

4 years ago
Thanks for review, nit fixed! Treeherder is green.

Master: https://github.com/mozilla-b2g/gaia/commit/322a161fa5d45675ca1e51bd7ef61f8b04b63426
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

4 years ago
Comment on attachment 8555341 [details] [review]
GitHub pull request URL

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): n/a
[User impact] if declined: Thread header font size won't be correctly set (will be lower than it can actually be)
[Testing completed]: yes, manual and unit
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8555341 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8555341 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/def9ac825fcb4bd1d53bd3e8e6348e111324a069
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S5 (6feb)
Created attachment 8636921 [details]
verified_Flame v2.2 Before.png

This bug has been verified as pass on latest build of Flame v2.2 & master and Nexus5 v2.2 & master.

STR:
1.Launch Messages app.
2.Create a new message.
3.Send a messages to a contact.

Actual results: The thread header font size is lower than before.

See attachment: verified_Flame v2.2 Before.png,verified_Flame v2.2 After.png

Reproduce rate: 0/5

Device: Flame v2.2 (Pass)
Build ID               20150720002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2d1f1f55803
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150720.042247
Firmware Date          Mon Jul 20 04:22:58 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Pass)
Build ID               20150720010206
Gaia Revision          3fac3ed7b8c887351098ffc677769ddc36abb3d0
Gaia Date              2015-07-17 17:53:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/202e9233d130
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150720.044158
Firmware Date          Mon Jul 20 04:42:10 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2 (Pass)
Build ID               20150720002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2d1f1f55803
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150720.041924
Firmware Date          Mon Jul 20 04:19:43 EDT 2015
Bootloader             HHZ12f

Device: Nexus5 master (Pass)
Build ID               20150720160206
Gaia Revision          4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gaia Date              2015-07-20 16:09:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d00e4167b482
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150720.191854
Firmware Date          Mon Jul 20 19:19:13 EDT 2015
Bootloader             HHZ12f
Created attachment 8636922 [details]
verified_Flame v2.2 After.png
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.