Flashblock extension prevents YouTube from properly playing videos correctly

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox36- wontfix)

Details

(Reporter)

Description

3 years ago
Even after clicking through the Flashblock's click-to-play feature, there are problems with YouTube videos. Usually, I wind up with no picture but perfectly working sound. The scrubber correctly shows video thumbnails, but the video frame itself is black.

Sometimes, the video plays but is dim, as if watching through a 50% opacity overlay.

For what it's worth, I reinstalled flashblock because the built-in click-to-play function has not worked reliably for me.

At least a couple other people in #developers have seen this same behavior (both with flashblock and the CTP feature).

Disabling Flashblock is confirmed to correct the problem with video playback on YouTube.

I wonder if this is at all related to being set up to play HTML5 video, but I can't figure out how to tell YouTube not to.
So (from your last sentence) Flashblock can block HTML5 videos, and this bug happens in that circumstance?
We are working on video playback for YouTube specifically in Firefox 36. cc Sheila, Benjamin, and Anthony as this bug with the Flashblock add-on may impact the perception of the work that we're doing with MSE.

Jorge - Can you alert the Flasblock add-on author about this bug?
Flags: needinfo?(jorge)
[Tracking Requested - why for this release]:
Not sure that we need to track this bug (as it may not be fixed in product) but wanted to ensure that Sylvestre sees it.
status-firefox36: --- → affected
tracking-firefox36: --- → ?
Eric, is this report on Mac OS? I thought we only enabled MSE on Windows.

I did some testing but couldn't reproduce. I'm adding the developer to this bug.
Flags: needinfo?(jorge) → needinfo?(eshepherd)
(In reply to Jorge Villalobos [:jorgev] from comment #4)
> Eric, is this report on Mac OS? I thought we only enabled MSE on Windows.

On Nightly MP4 MSE is enabled on both mac and windows.
(Reporter)

Comment 6

3 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #4)
> Eric, is this report on Mac OS? I thought we only enabled MSE on Windows.
> 
> I did some testing but couldn't reproduce. I'm adding the developer to this
> bug.

Yes, this is on Mac OS X 10.10.2 beta.
Flags: needinfo?(eshepherd)
Seems like it is going to be a wontfix for 36
status-firefox36: affected → wontfix
tracking-firefox36: ? → -
Blocks: 778617
Eric - does it play HTML5 video with MSE correctly without Flashblock on current nightly?
Flags: needinfo?(eshepherd)
Flags: needinfo?(mozillamarcia.knous)

Updated

3 years ago
Priority: -- → P2
I just tried a few youtube videos using the latest Beta and the latest version of Flashblock - 1.5.18

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20150217132925 CSet: 9e2391999085. I am running ahead on 10.10.3. Flash Version: 16.0.0.305

What I see at the moment on Beta is that once Flashblock is installed, the button that you are supposed to click to allow the video to play doesn't work at all for me.

I tried a whole bunch of different videos including https://www.youtube.com/watch?v=H-AqDhgRdP4

Without Flashblock, all the you tube videos I tried play fine both with flash and HTML5.
Flags: needinfo?(mozillamarcia.knous)
Flags: needinfo?(philip.chee)
(In reply to Marcia Knous [:marcia - use needinfo] from comment #9)
> I just tried a few youtube videos using the latest Beta and the latest
> version of Flashblock - 1.5.18
> 
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101
> Firefox/36.0 ID:20150217132925 CSet: 9e2391999085. I am running ahead on
> 10.10.3. Flash Version: 16.0.0.305
> 
> What I see at the moment on Beta is that once Flashblock is installed, the
> button that you are supposed to click to allow the video to play doesn't
> work at all for me.
> 
> I tried a whole bunch of different videos including
> https://www.youtube.com/watch?v=H-AqDhgRdP4
> 
> Without Flashblock, all the you tube videos I tried play fine both with
> flash and HTML5.

Given that MSE is disabled in beta you probably want to try it in nightly.
Flags: needinfo?(mozillamarcia.knous)

Comment 11

3 years ago
Yeah sorry about that I'll be coming up with a "really fixed" version of Flashblock Real Soon[TM].
Flags: needinfo?(philip.chee)
Flags: needinfo?(eshepherd)
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #10)

> Given that MSE is disabled in beta you probably want to try it in nightly.

Videos play fine in youtube.com using the latest nightly with and without Flashblock installed.
Flags: needinfo?(mozillamarcia.knous)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.