[NFC] Shrinking UI is blank when try to share received contact or file which opened from notification

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ashiue, Assigned: gduan)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Gaia-Rev        237008137f6d72b9cad25ff4faff14ff2c40ac63
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/be24dd482a83
Build-ID        20150122162504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150122.194331
FW-Date         Thu Jan 22 19:43:41 EST 2015
Bootloader      L1TC000118D0

STR:
1. Enable NFC on two phones
2. Phone A receive an image via bluetooth (or receive a contact)
3. Open the image(or contact) via notification
4. Tap 2 phones together
5. Check the shrinking UI

Expected result:
Shrinking UI shows correctly

Actual result:
Shrinking UI is blank, please refer the attached screenshot.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=NFC]
triage: regression
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(alive)
Keywords: regression
Flags: needinfo?(alive) → needinfo?(gduan)
QA Contact: bzumwalt
Assignee: nobody → gduan
Flags: needinfo?(gduan)
Unable to provide regression window as issue occurs on first mozilla-central-flame-kk-eng build available on PVT server. 

Device that has opened bluetooth received image displays a blank square on UI when NFC pairing is attempted.

While shallow flash central engineering builds are available, testing on these is blocked by https://bugzilla.mozilla.org/show_bug.cgi?id=1094527#c10 so that only Full flash builds can be used.

Device: Flame 2.2
Build ID: 20141106040023
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: a074c0112919
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [COM=NFC] → [COM=NFC][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=NFC][QAnalyst-Triage?] → [COM=NFC][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Posted file PR to master
Hi Alive,
could I have your review on this patch?
Thanks.
Attachment #8557860 - Flags: review?(alive)
Comment on attachment 8557860 [details] [review]
PR to master

this.frontWindow.isActive() otherwise the baseWindow will never hide overlay while frontWindow is closing
Attachment #8557860 - Flags: review?(alive)
Comment on attachment 8557860 [details] [review]
PR to master

Thanks advice!
patch is updated.
Attachment #8557860 - Flags: review?(alive)
Attachment #8557860 - Flags: review?(alive) → review+
Comment on attachment 8557860 [details] [review]
PR to master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a regression nor a feature.
[User impact] if declined:
User would see gallery app becoming blank when tilting down. And it also fix that, if user launch a sub window and go to cardview, we'll show the top window's screenshot after this patch.
[Testing completed]:
Yes, I've checked manually and written unit test to cover this fail.
[Risk to taking this patch] (and alternatives if risky):
I don't see risk if merged to 2.2 branch.
[String changes made]:
Attachment #8557860 - Flags: approval-gaia-v2.2?
Attachment #8557860 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

4 years ago
Verified on
[2.2]
Gaia-Rev        21cce750c095a3f815275fe5439fa9dbfe3dfc6b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/41ccc5328740
Build-ID        20150209162506
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150209.194557
FW-Date         Mon Feb  9 19:46:08 EST 2015
Bootloader      L1TC000118D0


[3.0]
Gaia-Rev        0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2cb22c058add
Build-ID        20150209160204
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150209.193059
FW-Date         Mon Feb  9 19:31:10 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.