[BlueDroid] Follow up bug for Bug 1059136 - expose BluetoothAdapter.uuids to v2.1 and v2.2

RESOLVED FIXED in Firefox OS v2.1

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jaliu, Assigned: jaliu)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed, b2g-master unaffected)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

4 years ago
[Bluedroid] Expose Adapter Uuids fields, we currently missed to add uuid into PropertyChange event at the beginning of supporting bluedroid. This creates failure on verifying API test cases. Please refer to Bug 1116878
(Assignee)

Updated

4 years ago
Blocks: 1116878
(Assignee)

Comment 1

4 years ago
Created attachment 8553576 [details] [diff] [review]
(for 2.1) [bluedroid] Expose adapter uuids field. (v0)
Assignee: nobody → jaliu
Status: NEW → ASSIGNED
Attachment #8553576 - Flags: review?(shuang)
(Assignee)

Comment 2

4 years ago
Created attachment 8553583 [details] [diff] [review]
(for 2.1) [bluedroid] Expose adapter uuids field. (v1), r=shuang

- add reviewer's name to commit message
- convert to hg format

Thank Shawn for reviewing the patch.
Attachment #8553576 - Attachment is obsolete: true
(Assignee)

Comment 3

4 years ago
[Blocking Requested - why for this release]:
Request for 2.1? since this bug blocks 2.1+ bug Bug 1116878.

Mozilla QA team is working on the release of MCTS for v2.1.
Please refer to https://bugzilla.mozilla.org/show_bug.cgi?id=970615#c44

The MCTS bluetooth tests would fail on v2.1 when it attempts to access 'BluetoothAdapter.uuids'. 'BluetoothAdapter.uuids' was exposed on Bug 1059136, however, the change didn't be applied to v2.1.
It blocks the release of MCTS v2.1 (Bug 970615 and Bug 1116878)
blocking-b2g: --- → 2.1?
(Assignee)

Comment 4

4 years ago
Comment on attachment 8553583 [details] [diff] [review]
(for 2.1) [bluedroid] Expose adapter uuids field. (v1), r=shuang

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
> Bug caused by (feature/regressing bug #):
Bug 1059136 - [Bluedroid] Expose Adapter Bluetooth Uuids field

> User impact if declined:
This MDN page [1] indicates that BluetoothAdapter can get Bluetooth service uuids from 'BluetoothAdapter.uuids'. However, the value of 'uuids' is invalid on FxOS v2.1 and would cause a JavascriptException: 'NS_ERROR_FAILURE'.

[1] https://developer.mozilla.org/en-US/docs/Web/API/BluetoothAdapter

Although 'BluetoothAdapter.uuids' hasn't been used by any build-in gaia app yet, it still a part of Bluetooth Web API. It means it have to be tested by MCTS (Firefox OS Certification Testsuite). Currently, it would blocks Bug 1116878.

> Testing completed: 
Use this value in setting app and print the UUID through adb logcat.

> Risk to taking this patch (and alternatives if risky): 
'BluetoothAdapter.uuids' is a rarely used property and it'll be removed from Bluetooth API v2 [2] on FxOS v3.

[2] https://wiki.mozilla.org/B2G/Bluetooth/WebBluetooth-v2/BluetoothAdapter#BluetoothAdapter

> String or UUID changes made by this patch:
no
Attachment #8553583 - Flags: approval-mozilla-b2g34?

Updated

4 years ago
blocking-b2g: 2.1? → 2.1+
shawn is this not needed on central/b2g37 ?
Flags: needinfo?(shuang)
In v3.0, this API no longer be exposed, but still need to patch for v2.2.
Jamin, can you confirm the patch can go into v2.2 directly or need rebase?
Flags: needinfo?(shuang) → needinfo?(jaliu)
(Assignee)

Comment 7

4 years ago
Created attachment 8555771 [details] [diff] [review]
(for 2.2) [bluedroid] Expose adapter uuids field. (v1), r=shuang
Flags: needinfo?(jaliu)
(Assignee)

Comment 8

4 years ago
Created attachment 8555772 [details] [diff] [review]
(for 2.2) [bluedroid] Expose adapter uuids field. (v1), r=shuang

- rebase
Attachment #8555771 - Attachment is obsolete: true
(Assignee)

Comment 9

4 years ago
(In reply to Shawn Huang [:shawnjohnjr] from comment #6)
> In v3.0, this API no longer be exposed, but still need to patch for v2.2.
> Jamin, can you confirm the patch can go into v2.2 directly or need rebase?

v2.1 patch can be cherry-pick to v2.2.
I've verified the patch on v2.2 by checking the value of BluetoothAdapter.uuid.
(Assignee)

Comment 10

4 years ago
Comment on attachment 8555772 [details] [diff] [review]
(for 2.2) [bluedroid] Expose adapter uuids field. (v1), r=shuang

The patch was cherry-pick from v2.1 patch.
Copy [Approval Request Comment] from #comment 4

[Approval Request Comment]
> Bug caused by (feature/regressing bug #):
Bug 1059136 - [Bluedroid] Expose Adapter Bluetooth Uuids field

> User impact if declined:
This MDN page [1] indicates that BluetoothAdapter can get Bluetooth service uuids from 'BluetoothAdapter.uuids'. However, the value of 'uuids' is invalid on FxOS v2.1 and would cause a JavascriptException: 'NS_ERROR_FAILURE'.

[1] https://developer.mozilla.org/en-US/docs/Web/API/BluetoothAdapter

Although 'BluetoothAdapter.uuids' hasn't been used by any build-in gaia app yet, it still a part of Bluetooth Web API. It means it have to be tested by MCTS (Firefox OS Certification Testsuite). Currently, it would blocks Bug 1116878.

> Testing completed: 
Use this value in setting app and print the UUID through adb logcat.

> Risk to taking this patch (and alternatives if risky): 
'BluetoothAdapter.uuids' is a rarely used property and it'll be removed from Bluetooth API v2 [2] on FxOS v3.

[2] https://wiki.mozilla.org/B2G/Bluetooth/WebBluetooth-v2/BluetoothAdapter#BluetoothAdapter

> String or UUID changes made by this patch:
no
Attachment #8555772 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8553583 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34+

Updated

4 years ago
Attachment #8555772 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+

Updated

4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected

Comment 11

4 years ago
Hi Ryan, can we land this patch? Thanks.
Flags: needinfo?(ryanvm)
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f98eb7d174df
https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9a4ef05c858d

In the future, please make sure the bug number in the commit message matches the bug the patch is landing under.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: affected → fixed
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → unaffected
Flags: needinfo?(ryanvm) → needinfo?(jaliu)
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S5 (6feb)
(Assignee)

Comment 13

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #12)
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f98eb7d174df
> https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9a4ef05c858d
> 
> In the future, please make sure the bug number in the commit message matches
> the bug the patch is landing under.

I'm so sorry.
I once uploaded this patch to bug 1116878 and I forgot to change the commit message when I moved it to here. It's a terrible mistake.

Sorry for any trouble caused.
Flags: needinfo?(jaliu)

Comment 14

4 years ago
Dear vance and shawn,

Please help land the change to v2.1s.

Thanks!
Flags: needinfo?(vchen)
Flags: needinfo?(sku)
Hi Steven -

Could you help to make sure this one land on 2.1s?

Thanks
Flags: needinfo?(sku) → needinfo?(styang)

Comment 16

4 years ago
https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/9a4ef05c858d
status-b2g-v2.1S: --- → fixed
Flags: needinfo?(vchen)
Flags: needinfo?(styang)
You need to log in before you can comment on or make changes to this bug.