[Flame][Homescreen] Unable to invoke keyboard successfully after tapping Rocket bar quickly.

VERIFIED WORKSFORME

Status

defect
VERIFIED WORKSFORME
5 years ago
4 years ago

People

(Reporter: liuyong, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Reporter

Description

5 years ago
[1.Description]:
[Flame][v2.2][Homescreen]Repeat tapping Reocket bar quickly, then the keyboard isn't invoked successfully sometimes.

Found time :13:31
Attachments: logcat_1331.txt, 1331.mp4

[2.Testing Steps]: 
1. Tap on the Rocket bar to invoke/hide keyboard quickly in Homescreen.
2. Repeat step 1 several times.

Note: The keyboard will not be invoked normally untill you restart device.

[3.Expected Result]: 
2. Keyboard should be invoked normally.

[4.Actual Result]: 
2. Can't invoke the keyboard successfully.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4a90da67661e
Build-ID        20150122002808
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150122.041326
FW-Date         Thu Jan 22 04:13:37 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,3/10

[7.TCID]:
Free Test
Reporter

Comment 1

5 years ago
Posted video Bug video: 1131.mp4
Reporter

Comment 2

5 years ago
Does it work in other apps like SMS afterwards?
Flags: needinfo?(liuyong)
Reporter

Comment 4

5 years ago
Hi Gregor,
     The keyboard works well in other APPs(SMS,Contacts,Calendar,E-mail). But it can't be invoked in Browser, hope this can help you! Thanks.
Flags: needinfo?(liuyong) → needinfo?(anygregor)
Kevin, any ideas?
blocking-b2g: --- → 2.2+
Flags: needinfo?(anygregor) → needinfo?(kgrandon)
Whiteboard: [systemsfe]
qawanted - Can we re-test this on 2.2 and master? I think that bug 1111524 may have fixed this, which didn't hit the 2.2 branch until after this was tested. I'm currently unable to reproduce on master.
Flags: needinfo?(kgrandon)
Keywords: qawanted
QA Contact: ychung
Unable to reproduce this issue on latest Flame 2.2 and Master.

Result: The keyboard appears properly when the rocketbar is selected.
Repro rate: 0/20

Device: Flame 2.2
BuildID: 20150128081631
Gaia: 46b590648007d51a0406b21b1d6f98eba8e3898e
Gecko: a51733ce32ca
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame Master
BuildID: 20150128052734
Gaia: ba613ae583a706131c45e885f65d428d4a541a81
Gecko: d8260c1a0689
Version: 38.0a1 (Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: ychung
Resolving as worksforme. Likely fixed by bug 1111524.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.